[Eric] eric 4.4.1 subprocess problem

Linos info at linos.es
Sat Feb 13 19:19:41 GMT 2010

Hi detlev,
	the problem it is not related to any code of mine in particular but interaction 
between my system and eric (it is the only qt/kde program where i get this 
behavior), i think it is related to kdelibs, qt or pyqt, the last time i had 
this problem was an upgrade to qt 4.5.3, later 4.6.0 was fine and now kdelibs 
4.4.0 with qt 4.6.0 (4.6.1) exhibits this problem.

The problem it is the keyboard get broken inside eric, i cant use the arrows in 
the editor or the delete key and the shorcuts gets broken too, for example Debug 
Project "Shift + F5" becomes F5 and Debug Script has the same key and none of 
them works using F5. Here i investigate a bit on the causes 
http://www.mail-archive.com/eric@riverbankcomputing.com/msg02074.html but still 
i have not cleared them. We had changing private emails about this problem in 
2009-10-23~24 but i was the only with this problem (and i suppose still the only 

Anyway thanks for your great support :) and eric it is a very good python ide, 
it is a great work on your side, i am impressed with it.

Miguel Angel.

El 13/02/10 19:45, detlev escribió:
> Hi,
> would you please send some short test code showing the problem. I#d like you
> to be back using eric.
> Regards,
> Detlev
> On Samstag, 13. Februar 2010, Linos wrote:
>> Thanks,
>> 	anyway i am unable to fix the other problem (i have tried to downgrade too
>>   many packages included qt and still eric it is broken) so i am stuck with
>>   vim for now.
>> Regards,
>> Miguel Angel.
>> El 13/02/10 14:01, detlev escribió:
>>> Hi,
>>> the issue will be fixed in the next release. Meanwhile one can get the
>>> latest sources from the source code repository.
>>> Regards,
>>> Detlev
>>> On Mittwoch, 10. Februar 2010, Linos wrote:
>>>> Hi,
>>>> 	i can reproduce with this simple code:
>>>> import subprocess, time
>>>> if __name__ == "__main__":
>>>>      subprocess.Popen(['soffice', '/tmp/prueba.csv'])
>>>>      time.sleep(100)
>>>>      print "ended sleep"
>>>> change prueba.csv for any openoffice document. Anyway i think this is
>>>>    related to the problem i am getting other time that i related first
>>>> time here
>>>> http://www.mail-archive.com/eric@riverbankcomputing.com/msg02056.html
>>>> argh.
>>>> El 10/02/10 19:12, detlev escribió:
>>>>> Hi,
>>>>> can you please generate a small test script that shows the problematic
>>>>> behavior? That would allow me to debug it.
>>>>> Regards,
>>>>> Detlev
>>>>> On Mittwoch, 10. Februar 2010, Linos wrote:
>>>>>> Hello,
>>>>>> 	i have upgraded today to version 4.4.1 and i now have a problem i had
>>>>>> not before upgrade, i have a line in code where i do this:
>>>>>> 	subprocess.Popen(["soffice", filename])
>>>>>> I use this to open a csv file i generate from code, with the new eric
>>>>>>     version i get a dialog where i have to choose "Parent process" or
>>>>>> "Child process", if i choose parent i get an excepcion from
>>>>>> subprocess.py (9, Bad file descriptor), if i choose child openoffice
>>>>>> loads the file cleanly but on close openoffice, eric close my program
>>>>>> too.
>>>>>> This same code works well if i launch the program directly without
>>>>>> eric. I have other lines in code where i use subprocess.call instead
>>>>>> of Popen but i get the same result. I am using python 2.6 in Linux
>>>>>> 2.6.32. How can i fix this? any configuration option? Thanks.
>>>>>> Regards,
>>>>>> Miguel Angel.
>>>>>> _______________________________________________
>>>>>> Eric mailing list
>>>>>> Eric at riverbankcomputing.com
>>>>>> http://www.riverbankcomputing.com/mailman/listinfo/eric

More information about the Eric mailing list