[PyKDE] sip/PyQt compiling problems

Phil Thompson phil at river-bank.demon.co.uk
Mon Sep 18 14:11:17 BST 2000

Karolina Lindqvist wrote:
> I wrote some programs in PyKDE, a while ago, but due to crashes etc. I lost
> the configuration and now I am trying to compile ANY version of PyKDE that
> works, but have so far been unsuccessful. It appears to be next to impossible
> to find any version of PyQT/PyKDE to match with any version of Qt/KDE that
> runs.
> So far I have tried PyQt etc. 2.0, with version 1.44, 1.45, 2.02 of QT, and
> none works. The nearest I get with qt-1.44 and kde-1.1.2, and PyKDE-0.12, but
> that combo gives a QT run-time error when the python program is executed. The
> .rpm-files that I have found, gives undefined symbols when loaded. Which one
> is varying with which version of qt/qt I use.
> As I supposed old version of PyQT/KDE is not supported, I have tried with
> version 2.0. This is what I get when trying to compile PyQt with Qt-2.2.0
> (the version of qt, is the one with the latest KDE 2.0 cvs snapshot):

SIP 2.0.1 and PyQt v2.0 should support all official releases of Qt (ie.
not beta releases) since v1.42. The only exception is Qt v2.1.0.

PyKDE (at the moment) only supports KDE v1.x. KDE v1.x requires Qt
v1.44. Therefore, if you want to use PyKDE then you must use Qt v1.44
and KDE v1.x.

The errors you describe all seem to be related to trying to compile
files from one version of moc against a different version of Qt. Moc
generated code is often not compatible between different versions of Qt.

When you move to a different version of Qt you *must* recompile SIP and
PyQt, and make sure you do it with completely clean sources.


More information about the PyQt mailing list