[PyKDE] problems building PyQt-3.0 for Qt v3

Markus A. Greiner mailings at greiners.net
Tue Dec 11 15:24:36 GMT 2001


I'm not able to install QTv3 version of PyQt 3. The version for 2.3.1
works great and I was able to compile and install it without any
trouble. Both versions of the library installed are installed:
one in "/usr/lib/qt-2.3.1" and the other in "/usr/lib/qt-3.0.0" 

But if I try to compile and install the QTv3 packet I ran into serious
trouble. After compiling (which runs without any error) during the
installation python tries to bytecompile some py files and breaks with
the following errormessage:

make[3]: Entering directory `/mnt/rpm/BUILD/PyQt-3.0/qt'
(cd /tmp;
PYTHONPATH=/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages:/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages /usr/bin/python -O -c "import qt")
Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages/qt.py", line
44, in ?
    import libqtc
ImportError: undefined symbol: static_QUType_ptr
make[3]: *** [install-data-hook] Error 1
make[3]: Leaving directory `/mnt/rpm/BUILD/PyQt-3.0/qt'
make[2]: *** [install-data-am] Error 2
make[2]: Leaving directory `/mnt/rpm/BUILD/PyQt-3.0/qt'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/mnt/rpm/BUILD/PyQt-3.0/qt'
make: *** [install-recursive] Error 1
Bad exit status from /var/tmp/rpm-tmp.18008 (%install)

Checking the created libs with ldd shows that they are dynamicly linked 
against QTv2 libs:

libsip.so.7 => /usr/lib/libsip.so.7 (0x4057e000)
libqt-mt.so.2 => /usr/lib/qt-2.3.1/lib/libqt-mt.so.2 (0x40590000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40a54000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40a5e000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40a76000)
libc.so.6 => /lib/libc.so.6 (0x40b59000)
libqt.so.2 => /usr/lib/qt-2.3.1/lib/libqt.so.2 (0x40c6c000)
libpthread.so.0 => /lib/libpthread.so.0 (0x4112d000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x41143000)
libXft.so.1 => /usr/X11R6/lib/libXft.so.1 (0x41151000)
libpng.so.2 => /usr/lib/libpng.so.2 (0x411ae000)
libz.so.1 => /lib/libz.so.1 (0x411d9000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x411e8000)
libmng.so.0 => /usr/lib/libmng.so.0 (0x41207000)

I also tried to compile and install the package without having the qt2 
libs in ld path by removing the qt2 entry in ld.so.conf. But after an
errorfree compiler run I got the message:

... shared object not open ...

instead of: 

ImportError: undefined symbol: static_QUType_ptr

and an ldd on the created libs shows:

libsip.so.7 => /usr/lib/libsip.so.7 (0x4057e000)
libqt-mt.so.2 => not found
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40a54000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40a5e000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40a76000)
libc.so.6 => /lib/libc.so.6 (0x40b59000)
libqt.so.2 => not found
libpthread.so.0 => /lib/libpthread.so.0 (0x4112d000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x41143000)
libXft.so.1 => /usr/X11R6/lib/libXft.so.1 (0x41151000)
libpng.so.2 => /usr/lib/libpng.so.2 (0x411ae000)
libz.so.1 => /lib/libz.so.1 (0x411d9000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x411e8000)
libmng.so.0 => /usr/lib/libmng.so.0 (0x41207000)

I'm curious. Is it correct that the libs are linked against QTv2 and
not QTv3. And if not -> what's wrong with my configuration. I can't find
any clue to get the modules working. 

Any help or hint would be appreciated.

I attached the specfile and config.log which contains my configure
options and other settings

--- other more or less usefull infos ---

Dist:   SuSE 7.1 
GCC:    2.95.2
LDD:    ldd (GNU libc) 2.2

QT   :  qt-2.3.1

GLIBC:  glibc-2.2-7
python: 2.1


-------------- next part --------------
Summary: Python bindings for Qt.
Name: PyQt
Version: 3.0
Release: qt3
Copyright: Phil Thompson <phil at river-bank.demon.co.uk>
Packager: Phil Thompson <phil at river-bank.demon.co.uk>
Group: Development/Languages/Python
Source: ftp://ftp.thekompany.com/pub/PyQt/%{name}-%{version}.tar.gz
URL: http://www.thekompany.com/projects/pykde/
BuildRoot: /tmp/%{name}-%{version}-root
Requires: sip = 3.0
Prefix: /usr
Patch0: PyQt-3.0-Qt-3.0.0-patch.1
Patch1: PyQt-3.0-Qt-3.0.0-patch.2
Patch2: PyQt-3.0-Qt-3.0.0-patch.3
Patch3: PyQt-3.0-Qt-3.0.0-patch.4

Python bindings for the Qt C++ class library.  Also includes a PyQt backend
code generator for Qt Designer and a debugger.

%package devel
Summary: SIP specification files for Qt.
Group: Development/Languages/Python

%description devel
The SIP specification files for the Qt class library.

%patch0 -p1
%patch1 -p1 
%patch2 -p1 
%patch3 -p1

LDFLAGS="-L/usr/lib/qt-3.0.0/lib -L$RPM_BUILD_ROOT%{prefix}/lib/python2.1/site-packages" \
./configure --with-qt-dir=/usr/lib/qt-3.0.0 --prefix=%{prefix}

make DESTDIR=$RPM_BUILD_ROOT install install-sip install-doc


%attr(-,root,root) %{prefix}/bin/eric
%attr(-,root,root) %{prefix}/bin/pyuic
%attr(-,root,root) %{prefix}/doc/%{name}
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/eric
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtcmodule-3.0.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtcmodule.la
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtcmodule.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qt.py
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qt.pyo
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtcanvascmodule-3.0.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtcanvascmodule.la
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtcanvascmodule.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtcanvas.py
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtcanvas.pyo
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtglcmodule-3.0.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtglcmodule.la
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtglcmodule.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtgl.py
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtgl.pyo
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtnetworkcmodule-3.0.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtnetworkcmodule.la
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtnetworkcmodule.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtnetwork.py
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtnetwork.pyo
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtsqlcmodule-3.0.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtsqlcmodule.la
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtsqlcmodule.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtsql.py
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtsql.pyo
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqttablecmodule-3.0.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqttablecmodule.la
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqttablecmodule.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qttable.py
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qttable.pyo
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtxmlcmodule-3.0.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtxmlcmodule.la
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/libqtxmlcmodule.so
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtxml.py
%attr(-,root,root) %{prefix}/lib/python2.1/site-packages/qtxml.pyo

%files devel
%attr(-,root,root) %{prefix}/share/sip/qt
-------------- next part --------------
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.52.  Invocation command line was

  $ ./configure --with-qt-dir=/usr/lib/qt-3.0.0 --prefix=/usr

## ---------- ##
## Platform.  ##
## ---------- ##

hostname = tranquility
uname -m = i686
uname -r = 2.4.16
uname -s = Linux
uname -v = #1 Mon Nov 26 22:00:29 CET 2001

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = i686
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH = /home/markus/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/lib/java/bin:/usr/games/bin:/usr/games:/opt/gnome/bin:/opt/kde2/bin:/opt/kde/bin:/usr/openwin/bin:.

## ------------ ##
## Core tests.  ##
## ------------ ##

configure:1119: PATH=".;."; conftest.sh
./configure: conftest.sh: command not found
configure:1122: $? = 127
configure:1168: checking for a BSD compatible install
configure:1217: result: /usr/bin/ginstall -c
configure:1228: checking whether build environment is sane
configure:1271: result: yes
configure:1304: checking for mawk
configure:1330: result: no
configure:1304: checking for gawk
configure:1319: found /usr/bin/gawk
configure:1327: result: gawk
configure:1337: checking whether make sets ${MAKE}
configure:1357: result: yes
configure:1487: checking for a BSD compatible install
configure:1536: result: /usr/bin/ginstall -c
configure:1596: checking for g++
configure:1611: found /usr/bin/g++
configure:1619: result: g++
configure:1634: checking for C++ compiler version
configure:1637: g++ --version </dev/null >&5
configure:1640: $? = 0
configure:1642: g++ -v </dev/null >&5
Reading specs from /usr/lib/gcc-lib/i486-suse-linux/2.95.2/specs
gcc version 2.95.2 19991024 (release)
configure:1645: $? = 0
configure:1647: g++ -V </dev/null >&5
g++: argument to `-V' missing

configure:1650: $? = 1
configure:1670: checking for C++ compiler default output
configure:1673: g++   -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.cc  >&5
configure:1676: $? = 0
configure:1705: result: a.out
configure:1710: checking whether the C++ compiler works
configure:1716: ./a.out
configure:1719: $? = 0
configure:1734: result: yes
configure:1741: checking whether we are cross compiling
configure:1743: result: no
configure:1746: checking for executable suffix
configure:1748: g++ -o conftest   -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.cc  >&5
configure:1751: $? = 0
configure:1773: result: 
configure:1779: checking for object suffix
configure:1797: g++ -c   conftest.cc >&5
configure:1800: $? = 0
configure:1819: result: o
configure:1823: checking whether we are using the GNU C++ compiler
configure:1844: g++ -c   conftest.cc >&5
configure:1847: $? = 0
configure:1850: test -s conftest.o
configure:1853: $? = 0
configure:1865: result: yes
configure:1871: checking whether g++ accepts -g
configure:1889: g++ -c -g  conftest.cc >&5
configure:1892: $? = 0
configure:1895: test -s conftest.o
configure:1898: $? = 0
configure:1908: result: yes
configure:1948: g++ -c -g -O2  conftest.cc >&5
configure:1951: $? = 0
configure:1954: test -s conftest.o
configure:1957: $? = 0
configure:1979: g++ -c -g -O2  conftest.cc >&5
configure:1982: $? = 0
configure:1985: test -s conftest.o
configure:1988: $? = 0
configure:2018: checking for style of include used by make
configure:2045: result: GNU
configure:2051: checking dependency style of g++
configure:2113: result: none
configure:2122: checking how to run the C++ preprocessor
configure:2144: g++ -E  conftest.cc
configure:2150: $? = 0
configure:2177: g++ -E  conftest.cc
configure:2174: ac_nonexistent.h: No such file or directory
configure:2183: $? = 1
configure: failed program was:
#line 2173 "configure"
#include "confdefs.h"
#include <ac_nonexistent.h>
configure:2220: result: g++ -E
configure:2235: g++ -E  conftest.cc
configure:2241: $? = 0
configure:2268: g++ -E  conftest.cc
configure:2265: ac_nonexistent.h: No such file or directory
configure:2274: $? = 1
configure: failed program was:
#line 2264 "configure"
#include "confdefs.h"
#include <ac_nonexistent.h>
configure:2385: checking build system type
configure:2403: result: i686-pc-linux-gnu
configure:2410: checking host system type
configure:2424: result: i686-pc-linux-gnu
configure:2474: checking for gcc
configure:2489: found /usr/bin/gcc
configure:2497: result: gcc
configure:2725: checking for C compiler version
configure:2728: gcc --version </dev/null >&5
configure:2731: $? = 0
configure:2733: gcc -v </dev/null >&5
Reading specs from /usr/lib/gcc-lib/i486-suse-linux/2.95.2/specs
gcc version 2.95.2 19991024 (release)
configure:2736: $? = 0
configure:2738: gcc -V </dev/null >&5
gcc: argument to `-V' is missing
configure:2741: $? = 1
configure:2744: checking whether we are using the GNU C compiler
configure:2765: gcc -c   conftest.c >&5
configure:2768: $? = 0
configure:2771: test -s conftest.o
configure:2774: $? = 0
configure:2786: result: yes
configure:2792: checking whether gcc accepts -g
configure:2810: gcc -c -g  conftest.c >&5
configure:2813: $? = 0
configure:2816: test -s conftest.o
configure:2819: $? = 0
configure:2829: result: yes
configure:2856: gcc -c -g -O2  conftest.c >&5
conftest.c:2: parse error before `me'
configure:2859: $? = 1
configure: failed program was:
#ifndef __cplusplus
  choke me
configure:2959: checking dependency style of gcc
configure:3021: result: none
configure:3035: checking for ld used by GCC
configure:3098: result: /usr/i486-suse-linux/bin/ld
configure:3107: checking if the linker (/usr/i486-suse-linux/bin/ld) is GNU ld
GNU ld version 2.10.91 (with BFD
configure:3119: result: yes
configure:3123: checking for /usr/i486-suse-linux/bin/ld option to reload object files
configure:3130: result: -r
configure:3135: checking for BSD-compatible nm
configure:3171: result: /usr/bin/nm -B
configure:3174: checking whether ln -s works
configure:3178: result: yes
configure:3185: checking how to recognise dependant libraries
configure:3363: result: pass_all
configure:3369: checking command to parse /usr/bin/nm -B output
configure:3450: gcc -c -g -O2  conftest.c >&5
configure:3453: $? = 0
configure:3457: /usr/bin/nm -B conftest.o \| sed -n -e 's/^.*[ 	]\([ABCDGISTW][ABCDGISTW]*\)[ 	][ 	]*\(\)\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2\3 \3/p' \> conftest.nm
configure:3460: $? = 0
configure:3512: gcc -o conftest -g -O2  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.c conftstm.o >&5
configure:3515: $? = 0
configure:3559: result: ok
configure:3568: checking how to run the C preprocessor
configure:3594: gcc -E  conftest.c
configure:3600: $? = 0
configure:3627: gcc -E  conftest.c
configure:3624: ac_nonexistent.h: No such file or directory
configure:3633: $? = 1
configure: failed program was:
#line 3623 "configure"
#include "confdefs.h"
#include <ac_nonexistent.h>
configure:3670: result: gcc -E
configure:3685: gcc -E  conftest.c
configure:3691: $? = 0
configure:3718: gcc -E  conftest.c
configure:3715: ac_nonexistent.h: No such file or directory
configure:3724: $? = 1
configure: failed program was:
#line 3714 "configure"
#include "confdefs.h"
#include <ac_nonexistent.h>
configure:3766: checking for dlfcn.h
configure:3776: gcc -E  conftest.c
configure:3782: $? = 0
configure:3801: result: yes
configure:3988: checking for ranlib
configure:4003: found /usr/bin/ranlib
configure:4012: result: ranlib
configure:4062: checking for strip
configure:4077: found /usr/bin/strip
configure:4086: result: strip
configure:4288: checking for objdir
configure:4299: result: .libs
configure:4314: checking for gcc option to produce PIC
configure:4464: result: -fPIC
configure:4468: checking if gcc PIC flag -fPIC works
configure:4488: gcc -c -g -O2 -fPIC -DPIC  conftest.c >&5
configure:4491: $? = 0
configure:4494: test -s conftest.o
configure:4497: $? = 0
configure:4533: result: yes
configure:4549: checking if gcc static flag -static works
configure:4570: gcc -o conftest -g -O2  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages -static conftest.c  >&5
configure:4573: $? = 0
configure:4576: test -s conftest
configure:4579: $? = 0
configure:4593: result: yes
configure:4604: checking if gcc supports -c -o file.o
configure:4624: gcc -c -g -O2 -o out/conftest2.o  conftest.c >&5
configure:4648: result: yes
configure:4653: checking if gcc supports -c -o file.lo
configure:4677: gcc -c -g -O2 -c -o conftest.lo  conftest.c >&5
configure:4680: $? = 0
configure:4683: test -s conftest.lo
configure:4686: $? = 0
configure:4707: result: yes
configure:4738: checking if gcc supports -fno-rtti -fno-exceptions
configure:4757: gcc -c -g -O2 -fno-rtti -fno-exceptions -c conftest.c  conftest.c >&5
configure:4760: $? = 0
configure:4763: test -s conftest.o
configure:4766: $? = 0
configure:4782: result: yes
configure:4793: checking whether the linker (/usr/i486-suse-linux/bin/ld) supports shared libraries
configure:5445: result: yes
configure:5450: checking how to hardcode library paths into programs
configure:5474: result: immediate
configure:5479: checking whether stripping libraries is possible
configure:5484: result: yes
configure:5495: checking dynamic linker characteristics
configure:5888: result: GNU/Linux ld.so
configure:5893: checking if libtool supports shared libraries
configure:5895: result: yes
configure:5898: checking whether to build shared libraries
configure:5919: result: yes
configure:5922: checking whether to build static libraries
configure:5926: result: no
configure:6544: checking whether -lc should be explicitly linked in
configure:6552: gcc -c -g -O2  conftest.c >&5
configure:6555: $? = 0
configure:6569: gcc -shared conftest.o  -v -Wl,-soname -Wl,conftest -o conftest 2\>\&1 \| grep  -lc  \>/dev/null 2\>\&1
configure:6572: $? = 0
configure:6585: result: no
configure:7176: checking for -fno-exceptions
configure:7203: g++ -o conftest  -O2 -fno-exceptions  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.cc  >&5
configure:7206: $? = 0
configure:7209: test -s conftest
configure:7212: $? = 0
configure:7229: result: yes
configure:7247: checking for python
configure:7264: found /usr/bin/python
configure:7275: result: /usr/bin/python
configure:7296: checking Python version
configure:7298: result: 2.1
configure:7301: checking for Python.h
configure:7322: result: /usr/include/python2.1
configure:7343: checking for lib-dynload
configure:7364: result: /usr/lib/python2.1
configure:7390: checking for sip.h
configure:7411: result: /usr/include/sip
configure:7445: checking for SIP runtime library
configure:7473: result: -L/usr/lib -lsip
configure:7495: checking for X
configure:7704: result: libraries /usr/X11R6/lib, headers /usr/X11R6/include
configure:7783: checking for moc
configure:7800: found /usr/lib/qt-3.0.0/bin/moc
configure:7811: result: /usr/lib/qt-3.0.0/bin/moc
configure:7837: checking for qobject.h
configure:7858: result: /usr/lib/qt-3.0.0/include
configure:7897: checking for Qt library
configure:7925: result: -L/usr/lib/qt-3.0.0/lib -lqt-mt
configure:8087: gcc -o conftest -g -O2  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.c   -L/usr/X11R6/lib -lX11 >&5
configure:8090: $? = 0
configure:8093: test -s conftest
configure:8096: $? = 0
configure:8222: checking for gethostbyname
configure:8259: gcc -o conftest -g -O2  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.c  >&5
configure:8262: $? = 0
configure:8265: test -s conftest
configure:8268: $? = 0
configure:8278: result: yes
configure:8399: checking for connect
configure:8436: gcc -o conftest -g -O2  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.c  >&5
configure:8439: $? = 0
configure:8442: test -s conftest
configure:8445: $? = 0
configure:8455: result: yes
configure:8515: checking for remove
configure:8552: gcc -o conftest -g -O2  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.c  >&5
configure:8555: $? = 0
configure:8558: test -s conftest
configure:8561: $? = 0
configure:8571: result: yes
configure:8631: checking for shmat
configure:8668: gcc -o conftest -g -O2  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages conftest.c  >&5
configure:8671: $? = 0
configure:8674: test -s conftest
configure:8677: $? = 0
configure:8687: result: yes
configure:8756: checking for IceConnectionNumber in -lICE
configure:8783: gcc -o conftest -g -O2  -L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages -L/usr/X11R6/lib conftest.c -lICE   >&5
configure:8786: $? = 0
configure:8789: test -s conftest
configure:8792: $? = 0
configure:8803: result: yes
configure:8851: checking for Qt version >= 300 and < 400
configure:8896: result: yes
configure:8901: checking for Qt version >= 220
configure:8939: result: yes
configure:8954: checking for Qt version >= 220
configure:8992: result: yes
configure:9009: checking for the Qt Canvas module
configure:9042: g++ -o conftest -fno-exceptions  -I/usr/include/python2.1 -I/usr/include/sip -I/usr/lib/qt-3.0.0/include -DQT_THREAD_SUPPORT  -I/usr/X11R6/include   -L/usr/lib/qt-3.0.0/lib conftest.cc -lqt-mt  -L/usr/X11R6/lib  -lSM -lICE -lX11  >&5
configure:9045: $? = 0
configure:9048: test -s conftest
configure:9051: $? = 0
configure:9075: result: yes
configure:9095: checking for the Qt OpenGL module
configure:9128: g++ -o conftest -fno-exceptions  -I/usr/include/python2.1 -I/usr/include/sip -I/usr/lib/qt-3.0.0/include -DQT_THREAD_SUPPORT  -I/usr/X11R6/include   -L/usr/lib/qt-3.0.0/lib conftest.cc -lqt-mt  -L/usr/X11R6/lib  -lSM -lICE -lX11  >&5
configure:9131: $? = 0
configure:9134: test -s conftest
configure:9137: $? = 0
configure:9161: result: yes
configure:9181: checking for the Qt Network module
configure:9214: g++ -o conftest -fno-exceptions  -I/usr/include/python2.1 -I/usr/include/sip -I/usr/lib/qt-3.0.0/include -DQT_THREAD_SUPPORT  -I/usr/X11R6/include   -L/usr/lib/qt-3.0.0/lib conftest.cc -lqt-mt  -L/usr/X11R6/lib  -lSM -lICE -lX11  >&5
configure:9217: $? = 0
configure:9220: test -s conftest
configure:9223: $? = 0
configure:9247: result: yes
configure:9267: checking for the Qt SQL module
configure:9300: g++ -o conftest -fno-exceptions  -I/usr/include/python2.1 -I/usr/include/sip -I/usr/lib/qt-3.0.0/include -DQT_THREAD_SUPPORT  -I/usr/X11R6/include   -L/usr/lib/qt-3.0.0/lib conftest.cc -lqt-mt  -L/usr/X11R6/lib  -lSM -lICE -lX11  >&5
configure:9303: $? = 0
configure:9306: test -s conftest
configure:9309: $? = 0
configure:9333: result: yes
configure:9353: checking for the Qt Table module
configure:9386: g++ -o conftest -fno-exceptions  -I/usr/include/python2.1 -I/usr/include/sip -I/usr/lib/qt-3.0.0/include -DQT_THREAD_SUPPORT  -I/usr/X11R6/include   -L/usr/lib/qt-3.0.0/lib conftest.cc -lqt-mt  -L/usr/X11R6/lib  -lSM -lICE -lX11  >&5
configure:9389: $? = 0
configure:9392: test -s conftest
configure:9395: $? = 0
configure:9419: result: yes
configure:9439: checking for the Qt XML module
configure:9472: g++ -o conftest -fno-exceptions  -I/usr/include/python2.1 -I/usr/include/sip -I/usr/lib/qt-3.0.0/include -DQT_THREAD_SUPPORT  -I/usr/X11R6/include   -L/usr/lib/qt-3.0.0/lib conftest.cc -lqt-mt  -L/usr/X11R6/lib  -lSM -lICE -lX11  >&5
configure:9475: $? = 0
configure:9478: test -s conftest
configure:9481: $? = 0
configure:9505: result: yes
configure:9606: creating ./config.status

## ----------------------- ##
## Running config.status.  ##
## ----------------------- ##

This file was extended by config.status 2.52, executed with
  > ./config.status 
on tranquility

config.status:10145: creating Makefile
config.status:10145: creating qt/Makefile
config.status:10145: creating qtcanvas/Makefile
config.status:10145: creating qtgl/Makefile
config.status:10145: creating qtnetwork/Makefile
config.status:10145: creating qtsql/Makefile
config.status:10145: creating qttable/Makefile
config.status:10145: creating qtxml/Makefile
config.status:10145: creating examples/Makefile
config.status:10145: creating doc/Makefile
config.status:10145: creating sip/Makefile
config.status:10145: creating pyuic/Makefile
config.status:10145: creating debugger/Makefile
config.status:10145: creating debugger/eric
config.status:10237: creating config.h

## ----------------- ##
## Cache variables.  ##
## ----------------- ##

ac_cv_env_LDFLAGS_value='-L/usr/lib/qt-3.0.0/lib -L/tmp/PyQt-3.0-root/usr/lib/python2.1/site-packages'
ac_cv_have_x='have_x=yes 		ac_x_includes=/usr/X11R6/include ac_x_libraries=/usr/X11R6/lib'
ac_cv_path_install='/usr/bin/ginstall -c'
ac_cv_prog_CPP='gcc -E'
ac_cv_prog_CXXCPP='g++ -E'
lt_cv_file_magic_test_file='/lib/libc.so.6 /lib/libc-*.so'
lt_cv_global_symbol_to_c_name_address='sed -n -e '\''s/^: \([^ ]*\) $/  {\"\1\", (lt_ptr) 0},/p'\'' -e '\''s/^[BCDEGRST] \([^ ]*\) \([^ ]*\)$/  {"\2", (lt_ptr) \&\2},/p'\'''
lt_cv_global_symbol_to_cdecl='sed -n -e '\''s/^. .* \(.*\)$/extern char \1;/p'\'''
lt_cv_path_NM='/usr/bin/nm -B'
lt_cv_prog_cc_pic=' -fPIC'
lt_cv_sys_global_symbol_pipe='sed -n -e '\''s/^.*[ 	]\([ABCDGISTW][ABCDGISTW]*\)[ 	][ 	]*\(\)\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2\3 \3/p'\'''

## ------------ ##
## confdefs.h.  ##
## ------------ ##

#define PACKAGE "PyQt"
#define VERSION "3.0"
#define HAVE_DLFCN_H 1

configure: exit 0

## ----------------------- ##
## Running config.status.  ##
## ----------------------- ##

This file was extended by config.status 2.52, executed with
  CONFIG_HEADERS  = config.h
  > ./config.status 
on tranquility

config.status:10237: creating config.h
config.status:10378: config.h is unchanged

More information about the PyQt mailing list