[PyKDE] Problem running PyQt 3.3 on Win2K

WELCH,DONALD J (HP-Vancouver,ex1) donald_welch at hp.com
Tue Jul 9 18:55:00 BST 2002

I am experiencing a problem that I cannot seem to figure out. Forgive me if
this is covered somewhere that I didn't know to look - I tried to locate an
answer to this on my own to no avail. 
Environment: AS Python 2.2.1-222, QT 3.0.4, and PyQT 3.3 on Win2K/SP2;
MySQL 4.0 on Mandrake 8.2. 
Problem: When I run the SQL examples (examples3\SQL) from the command line
(DOS box), all is fine (for example, sqltable4.py). I can invoke the samples
using "python sqltable4.py" or "pythonw sqltable4.py" and they run fine
(using Start | Run... also works OK). However, if I double click on the .py
file in the Windows explorer (.py files are associated with python.exe), I
get the error: "<QMYSQL3> database driver not found! Please make sure, ...
[Abort]". (creating a shortcut using "python.exe sqltable4.py" and running
that from the Explorer also fails the same way). Re-associating .py files
with pythonw.exe does not solve this problem.
Obviously there is some sort of difference in the system environment between
a DOS box and the Windows Explorer processes. (I do have QTDIR defined in
the system environment.)  I would use a debugger (Wing IDE, etc) to help
figure this out, but it doesn't fail when running in the debugger! 
Any help or insights would be much appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20020709/070303b0/attachment.html

More information about the PyQt mailing list