[PyKDE] Trying to build PyKDE for KDE 3

Alex Willmer siu99aw at rdg.ac.uk
Sat Jun 22 17:32:00 BST 2002

On Sunday 16 June 2002 9:44 pm, Jim Bublitz wrote:
> There are two things you can try:
> 1. Temporarily rename all KDE libs in /usr/lib. For example,
> rename /usr/lib/libkdecore.so -> /usr/lib/zlibkdecore.so. You'll
> need to do this for all variations of libDCOP, libkdecore,
> libkdeui, libkio, libkfile, libkparts, libkhtml, libkjs, libkspell,
> libkdeprint and libkdesu. Also in each of the subdirectories under
> PyKDE-3.2.4 (dcop and k*) delete any lib* files and .libs
> directories. Then re-run make - it should only re-link and not
> recompile. After installing, restore the lib names in /usr/lib.
> There may still be a problem at runtime however, depending on how
> the paths are arranged in the *.la file in site-packages.

This is what I've done, but with a complete recompile from a clean unpack, 
to be safe. This would appear to have solved the problem of picking up the 
kde 2 libraries.

> -OR-
> 2. In each of the *.sip-in files in PyKDE-3.2.4/sip/kde30 (for
> KDE3.0.0), find the *LIBADD line near the end (for example
> libkdeuicmodule_la_LIBADD) and in those lines, move '-L$$(libdir)'
> to the end of the list after all of the KDE libs/paths (watch out
> for the '\' line continuations). In PyKDE-3.2.4/lib/configure.in.in
> change 'qt-dir' to 'kde-dir' as above. Then ./configure;make. This
> will rebuild everything. 'libdir' is /usr/lib. I don't think this
> will cause any other problems and should fix the link path problems.

This was the first one I tried, I didn't work. I also tried editting the 
duplicate files in PyKDE-3.2.4/sip/kde30/ but without effect. Are one set 
of these generated from the other, or do they serve different functions.

> Looks like a lot of messing around either way :(

Not with the lovely automation of bash it wasn't :)

> It should be possible to run KDE2.2.2 and KDE3.0.0 on the same
> system, but PyKDE will only support one or the other as currently
> configured.
> As to the libkdecore.so.3/.so.4 problem, I'm not sure. Is there a
> libkdecore.so symlink in the search path pointing to the so.4 lib?

I think that was some sort of aberation on my part, it would appear that the 
files are now linking without resorting to symlinking so.4 to so.3.

Here is the (possibly different) problem I'm faced with, for some reason 
related to PyQT or sip kdefx is failing to link correctly, with the 
follwing error reported on make install:

make  install-data-hook
make[3]: Entering directory 
(cd /tmp; 
/usr/bin/python -c "import kdefx")
Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/usr/lib/python2.2/site-packages/kdefx.py", line 37, in ?
    import libkdefxc
ImportError: /usr/lib/python2.2/site-packages/libkdefxcmodule.so: undefined 
symbol: sipCast_QCommonStyle__FPCvP7_object

Having looked at the ldd output of these files I haven't spotted anything 
obviously wrong, I've posted the relevant information at:

www.alexwillmer.uklinux.net/make-20020622.log (big, 500k)

> Sorry you've had so much trouble - thanks again.

Thankyou for all the help, I'll have another look at this tonight.

Alex Willmer
mailto:siu99aw at rdg.ac.uk

More information about the PyQt mailing list