[PyKDE] Installing PyQt on Mandrake 9.1

Andy Neitzke neitzke at fas.harvard.edu
Sun Feb 9 15:32:01 GMT 2003


I would be really grateful for some help in installing PyQt on Mandrake
9.1 -- have been tearing my hair out over this.

The story so far:  Since the RPMs don't work for a variety of reasons, I
tried installing from the latest PyQt, SIP, QScintilla snapshots.  Good,
they build without a hitch.  But when I try to use them I get:

[andy at teleology andy]$ python
Python 2.2.2 (#2, Feb  5 2003, 10:40:08)
[GCC 3.2.1 (Mandrake Linux 9.1 3.2.1-5mdk)] on linux-i386
Type "help", "copyright", "credits" or "license" for more information.
>>> import qt
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.2/site-packages/PyQt/qt.py", line 25, in ?
    import libqtc
ImportError: /usr/lib/python2.2/site-packages/PyQt/libqtcmodule.so:
undefined symbol: _ZNK16QAssistantClient9classNameEv

I found some previous discussion of this error and the suggestion was
that it's because Mandrake's "make install" has improperly stripped the
symbols out of the QT libraries; the proposed solution was to build QT
myself and then copy the libraries from the build directory by hand.  So
I did this:  in particular, my QT directory /usr/lib/qt3/lib now has a
"libqassistantclient.a" which at least contains the string
"_ZNK16QAssistantClient9classNameEv".  Nevertheless, I still get the
error listed above.  Is there something I have to do to get PyQt to
recognize this library file?  (It is at least looking in the right
directory, because it complains if I get rid of libqt-mt.so.3.1.1.)

This happens with QT 3.1.1 and Python 2.2.2.  I am a relative novice to
the intricacies of Python and Linux shared libraries, so forgive me if
this is a spectacularly stupid question!  But I would be enormously
grateful to anyone who knows how to get rid of this error.


More information about the PyQt mailing list