[PyKDE] Builing PYQT on OS X for Fink python

Ed garlic39 at es3.us
Wed Aug 4 22:32:01 BST 2004

I had the same trouble getting PyQT working on the Mac as Russle Howe
describes below.  An additional symptom was that "import sip" worked
for Apple's /usr/bin/python but not for Fink's /sw/bin/python. Fink's
python is first in my path and the one I want to use. 

I fixed the problem by building sip with:

   python configure.py -p darwin-g++ INCDIR_QT=/sw/include/qt 
          CC=gcc CXX=g++ LINK=g++ LINK_SHLIB=g++ 
          LFLAGS_PLUGIN="-bundle -flat_namespace -undefined suppress"

I have Mac OS X Version 10.3.4, sip-4.0.1, PyQt-mac-gpl-3.12, and
python 2.3.3 from fink (/sw/bin/python, not /usr/bin/python).

There may be a better solution, but maybe this will help someone else...

-- Ed

On Wed Apr 28, 2004, Russel Howe wrote:

> I am using OS X 10.3.3 and am having trouble getting PyQT working.  I 
> am using fink python and fink qt 3.2.3
> Python 2.3.3 (#1, Apr 21 2004, 13:28:02)
> [GCC 3.3 20030304 (Apple Computer, Inc. build 1495)] on darwin
> Type "help", "copyright", "credits" or "license" for more information.
> sip-4.0rc3, and PyQt-mac-gpl-3.11.  My gcc reports the same version string 
> as above.
> everything builds fine (I have tried both shared and -k), but starting 
> python and doing import sip causes a Bus Error.
> import qt results in
> Python Fatal Error, interpreter not initialized (version mismatch?)
> Abort trap
> which occurs in Py_InitModule4 according to a gdb backtrace
> I have seen a few others on this list who had problems with OS X, but they 
> all got things working by using sip-4.0.  Any ideas?

More information about the PyQt mailing list