[PyKDE] PyKDE compatibility with KDE 3.3.2?

Jim Bublitz jbublitz at nwinternet.com
Sat Dec 18 07:13:25 GMT 2004

On Friday 17 December 2004 17:57, Jared Thirsk wrote:
> Hey all,

>  This is probably a known issue and I don't mean to rush anyone but I
> thought I'd bring it up since I don't think anyone else has.

>  I've got KDE 3.3.2 (and don't want to downgrade), and pykde-3.11.3
> (Gentoo refuses to combine these two but I overrid that and tried it
> anyway), and this is the build error I get.  I'm wondering if this is
> a known compatibility problem and a basic idea of when it might be
> resolved:

The problem is that the build code for 3.11-3 has some problems that prevent 
it from correctly determining the files needed for KDE versions > 3.3.0. It 
wouldn't pick up any new methods in 3.3.1 or 3.3.2 anyway, but there aren't 
many of those. It should build for all of the 3.3.0 features that are in the 
newer versions.

I have a snapshot ready that should fix the problem (haven't tested against 
3.3.2 yet, but I don't expect any problems). The delay is that I need to make 
some changes to maintain future sip compatibility, which I've owed to Phil 
for about a week. I'll try to get those done tomorrow and get a copy to Phil, 
so a workable snapshot (complete through 3.3.1) should be available early 
next week.

In the meantime, what should work is going into KDE's kdeversion.h (in your 
case the one in /usr/kde/3.3/include) and change the smallest version number 
from 2 to 0 in any of the #defines that reference it so PyKDE thinks it's 
building for 3.3.0. You can change it back to the correct value after 
building PyKDE. There are other ways to accomplish it that are cleaner, but 
I'll probably have a working version available before you'd get the more 
complicated method working, as it involves changes for the setup of each of 
the modules.


More information about the PyQt mailing list