[PyKDE] PyKDE-3.11 final release

Troy Melhase troy at gci.net
Mon Jun 14 11:41:01 BST 2004

On Sunday 13 June 2004 11:12 pm, Jim Bublitz wrote:
> Please check kmanagerselection.sip and make sure all classes have the
> following %TypeHeaderCode blocks:
> %TypeHeaderCode
> #include <qdockwindow.h>
> #include <qvariant.h>
> #include <kmanagerselection.h>
> %End

Two classes in that file, KSelectionOwner and KSelectionWatcher .  Both have 
that include block.

> although from the line numbers in the error msg it appears they do. This
> appears to be a problem with the header files for kmanagerselection.h.
> Sticking in the q*.h files (which usually is unnecessary) fixed it here.
> For the moment the only thing I can suggest is going into
> sip/kdecore/kdecoremod.sip.in and commenting out the line as shown:
> // %Include kmanagerselection.sip
> which is probably what I'll end up doing for now. It takes a lot of time
> (recompiles) to figure these out, since they're usually just trial and
> error.

I tried this and got the same error.

> I believe I only had this problem only when building with the '-i' switch
> to configure.py (no concatenation of C++ files).

I didn't do that.  I ran configure.py without arguments.

> I can't duplicate either problem here, but I think I can come up with a
> solution that works generally. I'll need to do some testing on it though,
> so. I'll probably get to it sometime tomorrow. I'll release a new version
> (PyKDE-3.11.1) when I have that all completed.
> Since I don't get these errors, I'd be curious to know what distribution
> and gcc version you're running.

Gentoo Linux and a recent version of GCC:

$ uname -a
Linux whiterabbit 2.6.5-mm1 #3 Sat May 29 23:06:03 AKDT 2004 i686 AMD 
Athlon(tm) Processor AuthenticAMD GNU/Linux

$ gcc -v
Reading specs from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.3/specs
Configured with: /var/tmp/portage/gcc-3.3.3-r6/work/gcc-3.3.3/configure 
--prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/3.3 
--infodir=/usr/share/gcc-data/i686-pc-linux-gnu/3.3/info --enable-shared 
--host=i686-pc-linux-gnu --target=i686-pc-linux-gnu --with-system-zlib 
--enable-languages=c,c++,f77 --enable-threads=posix --enable-long-long 
--disable-checking --disable-libunwind-exceptions --enable-cstdio=stdio 
--with-local-prefix=/usr/local --enable-shared --enable-nls 
--without-included-gettext --disable-multilib --enable-__cxa_atexit 
Thread model: posix
gcc version 3.3.3 20040412 (Gentoo Linux 3.3.3-r6, ssp-3.3.2-2, pie-8.7.6)

The GCC installation is relatively new (meaning I installed this version since 
last building kde and qt).  Could that be to blame?

Thanks for all your help.

Troy Melhase, troy at gci.net
I have sworn upon the altar of God eternal hostility against every form of 
tyranny over the mind of man. - Thomas Jefferson

More information about the PyQt mailing list