[PyKDE] pyKDE 0628 snapshot doesn't compile anymore with newer sip

Danny Pansters danny at ricin.com
Mon Aug 22 14:16:27 BST 2005

First of all, thanks for all the hard work.

I'm having a problem building pyKDE with the new sip. The last version that I 
succesfully tested was 0727. With 0819 and 0821 I get this, and from the 
looks of it it's possibly a problem that other modules may also have:

c++ -c -Wno-deprecated-declarations -pipe -fPIC -O2 -fno-strict-aliasing -pipe 
-Wall -W -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -I. -I../extra/kde340 
-I/usr/local/include -I/usr/local/include/python2.4 -I/usr/X11R6/include -o 
sipdcoppart0.o sipdcoppart0.cpp
sip/dcop/dcopclient.sip: In function `PyObject* 
sip/dcop/dcopclient.sip:201: error: invalid conversion from `int' to 
*** Error code 1

pyQt as of last week seems to work fine (and fast!).

I'm using KDE-3.4.1, sip from 0821, pyQt from 0817, pyKDE from 0628 on 
FreeBSD6, system compiler is gcc-3.4.4.

This may already be a known problem. If there's anything I can do to test let 
me know. Please CC me if replying, I'm not subscribed to the list.



More information about the PyQt mailing list