[PyKDE] Problem running pyqt4 on dapper

Jesse J. Wattenbarger jesse.j.wattenbarger at gmail.com
Wed Dec 28 17:57:23 GMT 2005


I was having the problem mentioned here:

Commenting those lines out worked, but then I got a new undefined symbol:
omie at dagur:~/projects/PyQt4-gpl-snapshot-20051222/examples/tutorial$ python
Traceback (most recent call last):
  File "./t1.py", line 7, in <module>
    from PyQt4 import QtGui
ImportError: /home/omie/usr/lib/python2.4/site-packages/PyQt4/QtCore.so:
undefined symbol: PyUnicodeUCS4_GetDefaultEncoding

I can't seem to shake this.  Also of note, I started using a python snapshot
and that allowed me to avoid commenting out anything in the sip files and
prevented the previous undefined symbol (the one with QBitArray).  However,
I still get the PyUnicodeUCS4_GetDefaultEncoding error.

Any ideas?  I'm going to try to get a newer PyQt4 snapshot, and I'll see
what happens with that.

,----[ Jesse J. Wattenbarger ]--------------------------
|   jesse.j.wattenbarger at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20051228/2ec1a54d/attachment.html

More information about the PyQt mailing list