[PyKDE] Latest sip snapshot & PyKDE

Jim Bublitz jbublitz at nwinternet.com
Fri Dec 30 18:14:07 GMT 2005

On Friday 30 December 2005 08:21, Ismail Donmez wrote:
> I am trying to use PyQt4 and PyQt with PyKDE in the same system. So I
> upgraded to latest sip , PyQt4 and PyQt snapshots and all worked fine. But
> I can't get PyKDE to compile:
> cartman at southpark PyKDE-snapshot20051013 $ python configure.py -i -c

Use either -i or -c (or neither - configure.py for PyKDE will choose the 
correct mode based on the gcc version). That shouldn't be a problem, but it 
might be giving sip conflicting switches - try that first.

>      PyKDE version 4.0.0
>            -------
> Python include directory is /usr/include/python2.4
> Python version is 2.4.2
> sip version is snapshot-20051229 (4.3.0)
> Qt directory is /usr/qt/3
> Qt version is 3.3.5
> PyQt directory is /usr/share/sip
> PyQt version is snapshot-20051228 (3.16.0)
> KDE base directory is /usr/kde/3.5
> KDE include directory is /usr/kde/3.5/include
> KDE lib directory is /usr/kde/3.5/lib
> lib directory is lib
> *** True KDE version is 0x30500 -- building for KDE 0x30400 ***
> KDE version is 3.4.0 (0x30400)
> PyKDE modules will be installed in /usr/lib/python2.4/site-packages
> PyKDE .sip files will be installed in /usr/share/sip
> PyKDE modules to be built:
>    dcop kdecore kdefx kdeui kio kutils kfile kparts khtml kspell kdeprint
> kmdi
> Generating the C++ source for the dcop module...
> Creating the Makefile for the dcop module...
> Generating the C++ source for the kdecore module...
> sip: Ptr is undefined
> Error: Unable to create the C++ code.
> If reporting errors, paste all of the output above into your
> message and post to the PyKDE mailing list at:
>      mailto:    PyKDE at mats.imk.fraunhofer.de
>      subscribe: http://mats.imk.fraunhofer.de/mailman/listinfo/pykde
> You can redirect the output into a file (> output.txt) if needed
> Anyone knows a possible solution for this or do I have to wait for a new
> PyKDE snapshot?

There are 3 or 4 classes that have a Ptr member, and all of their code looks 
OK. I didn't find an unqualified or undefined use of Ptr, and in fact if 
there was one, it should have shown up. It compiles fine here, so there's no 
likelihood I can duplicate the bug to troubleshoot it. The only things I can 
suggest are: 

1. Check sip/kdecore/kdecoremod.sip for kconfig.sip, klockfile.sip, and 
kmountpoint.sip (should all be present). kdecoremod.sip is generated, so no 
point in editing it.  If any are missing, look at 2-4 to see how to restore 

2. In sip/kdecore/kdecore-340.diff, comment out one of klockfile.sip or 
kmountpoint.sip and see what happens - there isn't anything else that depends 
on them, so if the problem is in one of those, it should disappear.

3. In sip/kdecore/kdecoremod.sip.in (make sure it's the .in file), comment out 
kconfig.sip - I don't think that'll do much good though, as there are a lot 
of classes that depend on that.

4. If you didn't find the 3 files in their respective locations in 2 or 3, 
that could be the problem too - just add them into the .diff or .in file 
appropriately and try again.

There were some problems with the way the *mod.sip files get built (they 
determine which *.sip files go into a build), but I thought it only affected 
KDE 3.0.x versions - if you find missing files there, I can point to a 
repaired snapshot, but at this point I don't think that's necessary. It could 
also be the sip version, but that seems unlikely. I haven't tried the latest 
sip snapshot, but fairly recent versions have worked with PyKDE - I'll try 
that when I get a chance, probably tonight.

I'll be out most of the day - we got about a foot of snow overnight, and I'll 
be spending most of the day on the tractor snowblowing, but will check back 
when I can if you post any results.


More information about the PyQt mailing list