[PyKDE] QTimers on MacOSX?

Emanuele Santos emanuelesantos at gmail.com
Wed Apr 12 02:54:06 BST 2006

Ok, this is the problem

It seems that the python source is hardcoded to build only to ppc  
architecture. So I did this:
Used the same command line Andy suggested and later edited the  
generated Makefile changing the -arch_only ppc to -arch_only i386, so  
it builds fine.
When I try installing as framework I got the following error:
> Traceback (most recent call last):
>   File "./Mac/scripts/cachersrc.py", line 44, in ?
>     main()
>   File "./Mac/scripts/cachersrc.py", line 41, in main
>     os.path.walk(dir, handler, (verbose, force))
>   File "./Lib/posixpath.py", line 290, in walk
>     func(arg, top, names)
>   File "./Mac/scripts/cachersrc.py", line 23, in handler
>     macresource.open_pathname(os.path.join(dirname, fn),  
> verbose=verbose)
>   File "/Users/csilva/Desktop/Python-2.4.3/Lib/plat-mac/ 
> macresource.py", line 93, in open_pathname
>     pathname = _decode(pathname, verbose=verbose)
>   File "/Users/csilva/Desktop/Python-2.4.3/Lib/plat-mac/ 
> macresource.py", line 145, in _decode
>     applesingle.decode(pathname, newpathname, resonly=1)
>   File "/Users/csilva/Desktop/Python-2.4.3/Lib/plat-mac/ 
> applesingle.py", line 122, in decode
>     as = AppleSingle(infile, verbose=verbose)
>   File "/Users/csilva/Desktop/Python-2.4.3/Lib/plat-mac/ 
> applesingle.py", line 58, in __init__
>     raise Error, "Unknown AppleSingle magic number 0x%8.8x" % (magic,)
> applesingle.Error: Unknown AppleSingle magic number 0x00160500
> make[1]: *** [installmacsubtree] Error 1
> make: *** [frameworkinstallmaclib] Error 2

However, running make install works fine. And PyQt4 also works fine  
now. My problem now is with PyOpenGL. I know that this is not the  
best place to start asking, but anyways, has anybody got PyOpenGL  
built on an intel mac? Or found a suitable binary package?



On Apr 11, 2006, at 8:25 AM, Andy Davidoff wrote:

> I just built Python-2.4.3 from source on an intel Mac with exactly  
> the same ./configure command.
> This is on an older patchlevel of OS X:
> 	ProductName:    Mac OS X
> 	ProductVersion: 10.4.4
> 	BuildVersion:   8G32
> I will look into whether we've successfully deployed PyQt4 on any  
> intel Macs.  I know we ran into a couple issues, but perhaps we  
> solved them.
> On Apr 10, 2006, at 11:13 PM, Emanuele Santos wrote:
>> Using the hint that Andy Davidoff posted some days ago in the pyqt- 
>> mac list to compile python 2.4.2 from source:
>>   DYNLOADFILE=dynload_shlib.o ./configure --enable-framework -- 
>> enable-
>> toolbox-glue --enable-shared
>> I could run PyQt4 on a Mac G5 PPC. My problem now is with the mac  
>> intel. On the MacBook Pro, if I use Python that comes with it or  
>> the binary installation (2.4.3) I get the same ImportError  
>> incorrect format for dynamic loading. I tried to compile Python  
>> from source on a mac intel with no success.
> _______________________________________________
> PyKDE mailing list    PyKDE at mats.imk.fraunhofer.de
> http://mats.imk.fraunhofer.de/mailman/listinfo/pykde

Emanuele Santos
emanuelesantos at gmail.com

"God is always present though sometimes hidden.
Always caring, but often silent. "

Reclaim Your Inbox!

More information about the PyQt mailing list