[PyKDE] sip searchs incorrectly for qmail specs

Hai Zaar haizaar at gmail.com
Wed Mar 1 22:36:03 GMT 2006

Dear, list!

No matter what I've tried, I've failed to compile sip-4.3.2 - it
failed to find qmail specs.

I have qt compiled and installed to /usr with the following configure options:

/configure -prefix /usr \
            -docdir /usr/share/doc/qt \
            -headerdir /usr/include/qt \
            -plugindir /usr/lib/qt/plugins \
            -datadir /usr/share/qt \
            -translationdir /usr/share/qt/translations \
            -sysconfdir /etc/qt \
            -qt-gif \
            -system-zlib \
            -system-libpng \
            -system-libjpeg \
            -system-libmng \
            -plugin-imgfmt-png \
            -plugin-imgfmt-jpeg \
            -plugin-imgfmt-mng \
            -no-exceptions \
            -thread \
(I'm using Linux From Scratch distro)

kdebindings-3.5.1, which has sip bundles fails to compiles with
exactly the same error.

I've attached straightforward patch to fix the problem for me, but I'm
not sure if this is the right solution, since I'm unfamiliar both with
qt and python :), although things seem to work.

P.S. I'm not on the list, so please CC me.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: sip-4.3.2-qmake-specs-1.patch
Type: text/x-patch
Size: 840 bytes
Desc: not available
Url : http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20060301/702a956f/sip-4.3.2-qmake-specs-1.bin

More information about the PyQt mailing list