[PyKDE] python 2.5 and pyKDE (was: compile error for pyqt)

Jim Bublitz jbublitz at nwinternet.com
Thu Nov 23 21:44:05 GMT 2006

On Thursday 23 November 2006 09:48, Jonathan Riddell wrote:
> On Wed, Nov 22, 2006 at 11:05:19PM +0000, Jonathan Riddell wrote:
> > When compiling pyqt 3 (3.16)  with sip 4.5 I get an error
> >
> > sip: QColor::rgb() has overloaded functions with the same Python
> > signature
> Google found the fix being that I just needed pyqt 3.17.
> However now I'm having a problem compiling pykde with python 2.5.
> Python 2.4 works fine but 2.5 fails complaining about not being able
> to convert int*.
> Error at
> http://kubuntu.org/~jriddell/tmp/pykde.text

The type Py_ssize_t isn't defined in Python 2.4. I don't have Python 2.5 
anywhere at the moment, so I can't tell if a long term fix is possible 
without some conditional code for Python 2.5 (don't know what type Py_ssize_t 

If you want a quick fix, just find the offending variables and cast them to 
Py_ssize_t (or declare them to that type). 

I have a turkey to cook at the moment, so I won't be getting to this today.


More information about the PyQt mailing list