[PyKDE] Commercial PyQt4 and Qt4.2 on Mac OSX

V. Armando Sole sole at esrf.fr
Wed Oct 25 10:18:14 BST 2006


At 15:35 24/10/2006 -0600, Emanuele Santos wrote:
>Hi Phil,
>When are you planning to test PyQt4 and Qt4.2 on a mac?
>I can't even get PyQt4 configured:
>$ python configure.py -q /usr/bin/qmake
>Determining the layout of your Qt installation...
>Error: /usr/bin/qmake failed to create a makefile. Make sure you have a 
>Qt v4 qmake on your PATH or use the -q argument to explicitly specify a 
>Qt v4 qmake.
>I am using the binary distribution of Commercial Qt4.2 and the latest 
>commercial snapshot of Pyqt4 and the latest snapshot of sip.

What python are you using?

No problem here on a MacIntel with the GPLed version of Qt 4.2.1 and latest 
snapshots of sip and PyQt4. I use the python supplied with the mac (2.3). I 
did not use the Qt binary distribution but compiled the Qt libraries myself.


More information about the PyQt mailing list