[PyQt] PyKDE4 Update

Andreas Pakulat apaku at gmx.de
Tue Sep 4 20:32:08 BST 2007

On 04.09.07 11:35:07, Jim Bublitz wrote:
> But for example, knewstuff installs dxsengine.h in users include/ directory. 
> dxsengine.h depends on coreengine.h, which isn't installed. Not knowing 
> anything about knewstuff, I don't know if I should a) drop dxsengine from the 
> module or b) add coreengine.h (and associated sip file) to PyKDE or c) keep 
> dxsengine but eliminate the dependency on coreengine (coreengine provides a 
> base class  - I can not tell sip about the base class and the dependency is 
> solved, but all inherited methods are lost) or d) write some code manually to 
> fix the problem (I can restore some or all of the inherited methods manually 
> without coreengine or do other things). 

I think you should update your KDE4 or remove your install dir. Current
svn doesn't install that file anymore. It only installs the stuff in
knewstuff2/core and the engine.h from knewstuff2 (and the ui header).


Tomorrow, this will be part of the unchangeable past but fortunately,
it can still be changed today.

More information about the PyQt mailing list