[PyQt] subprocess.Popen() crash after QApplication() ?

Brian Kelley kelley at eyesopen.com
Tue Dec 2 18:57:51 GMT 2008

It's actually way more complicated than that and I don't think it has to do with multiple threads, just with improper signal handling.  Just running normal python I can trigger this error by:

Import webbrowser

A good write up of the problem as originally discovered is here:


I have solved(?) this problem by copying over python 2.6's subprocess module (and webbrowser.py) and importing them locally.  The 2.5 version also appears to work in my embedded python interpreter that runs Qt applications.  It has never worked in the standard python interpreter.

You may think about using QProcess in your python Qt application as opposed to subprocess, I'm thinking about wrapping the subprocess API and using a QProcess underneath the hood so I can easily swap them out.

Brian Kelley

On 12/2/08 1:27 PM, "Giovanni Bajo" <rasky at develer.com> wrote:

On 12/2/2008 6:43 PM, Denis wrote:
> Folks,
>   has anyone else seen this  or is it me ?
> Thanks, cheers

Oh yes: subprocess is absolutely useless on Mac with threading programs
(QApplication probably creates a thread behind the scenes):

Giovanni Bajo
Develer S.r.l.
PyQt mailing list    PyQt at riverbankcomputing.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20081202/8146214b/attachment.html

More information about the PyQt mailing list