[PyQt] jpeg plugin not loading

Doug Bell dougb at bellz.org
Thu Oct 23 12:17:18 BST 2008

Phil Thompson wrote:
> On Thu, 16 Oct 2008 08:02:11 -0400, Doug Bell <dougb at bellz.org> wrote:
> > Hi,
> > 
> > The plugin for jpeg image support is not loading on my windows
> > installation of PyQt (from the 4.4.3-1 binary installer).  Jpeg images
> > don't show up in a QTextBrowser and jpeg isn't listed as one of the
> > supported formats in QImageReader.supportedImageFormats().
> > 
> > This works fine on Linux and on someone else's windows installation, but
> > not on mine.  I'm not sure whether it matters, but I don't have an
> > administrator login to the only windows PC that I have access to.  Does
> > the PyQt install fail to properly setup plugins if installed as a
> > regular user?
> > 
> > Do I need to complie Qt and PyQt from source to get this to work?
> It should work.

It should?  I just tried this on another Windows PC - a laptop with an
older (4.3.0) binary installation of PyQt.  Jpeg image support worked
fine.  But images quit working after I upgraded to the 4.4.3 binary

The only thing that is slightly unusual about both of these PCs is that
I don't have an admin login - I'm just a regular user.

Any ideas?


More information about the PyQt mailing list