[PyQt] PyQt compile failure

aalto aallonsimo at gmail.com
Wed Sep 9 14:04:15 BST 2009

Phil Thompson-5 wrote:
> On Sun, 6 Sep 2009 11:29:57 -0700, "Glenn Tarbox, PhD" <glenn at tarbox.org>
> wrote:
>> On Sun, Sep 6, 2009 at 12:42 AM, Phil Thompson
>> <phil at riverbankcomputing.com>wrote:
>>> On Sat, 5 Sep 2009 19:31:14 -0700, "Glenn Tarbox, PhD"
> <glenn at tarbox.org>
>>> wrote:
>>> > I'm trying to compile the latest snapshot of PyQt and got the compile
>>> error
>>> > below.
>>> >
>>> > I'm pulling Qt from the git repo, so I tried the 4.6 stable branch as
>>> well
>>> > as a previous PyQt snapshot (from 8/21).  4.6 stable is dated 8/30.  I
>>> > think
>>> > all combinations were tried but the failure is in the ScopedPointer
>>> > stuff
>>> > which is pretty new IIRC.
>>> >
>>> > It would be useful to know if PyQt is being tested against the Qt git
>>> repo
>>> > and, if so, what checkin.  Qt is a moving target so I realize there's
>>> > trickiness.  In the past, I've found that in a few days time either Qt
>>> > or
>>> > PyQt has found and fixed bugs like this.
>>> PyQt is only ever tested against released versions of Qt.
>> Makes sense.
>> I do a fairly substantial amount of automated updating / building /
> testing
>> of Qt as it evolves.  PyQt is an integral component of my system and I
> use
>> it with the Mayavi2 tool suite integrated in Sage.
>> I'd be willing to forward any bugs like this if it helps... I could send
>> them to the main PyQt list although it might be more noise than signal if
>> I'm the only one working with the bleeding edge Qt repos.
>> I'll post them if you like, or send them somewhere else if you want a
> heads
>> up on issues I find.  Or not... let me know if you'd like these bug
>> reports.
> Thanks, but it wouldn't help. They are only bugs if they still exist when
> the version of Qt is released.
> Phil
> _______________________________________________
> PyQt mailing list    PyQt at riverbankcomputing.com
> http://www.riverbankcomputing.com/mailman/listinfo/pyqt


I came across this same issue. I've understood that the problem should be
fixed by declaring private
copy constuctor in qresource.h (see "Forward Declared Pointers" in
/qscopedpointer.html) but even if I do that, SIP still wants to generate a
public copy constructor in the
sipQtCoreQResources.cpp and it does not compile.

This is how it looks in the generated .cpp file:

class sipQResource : public QResource
    sipQResource(const QString&,const QLocale&);
    sipQResource(const QResource&);

     * There is a public method for every protected method visible from
     * this class.
    QStringList sipProtect_children() const;
    bool sipProtect_isDir() const;
    bool sipProtect_isFile() const;

    sipSimpleWrapper *sipPySelf;

    sipQResource(const sipQResource &);
    sipQResource &operator = (const sipQResource &);

I'm not too familiar with how SIP works but on a quick glance, should the
public cc actually be there?
Sorry for spamming if this is something obvious.

View this message in context: http://www.nabble.com/PyQt-compile-failure-tp25314147p25364554.html
Sent from the PyQt mailing list archive at Nabble.com.

More information about the PyQt mailing list