[PyQt] DLL Problem with PyQt-Py3.1-gpl-4.7.3-1.exe

Scott Ballard scott at scottballard.net
Mon Apr 19 17:00:54 BST 2010

I noticed this issue when I've installed the 4.7.x releases under Python 2.6. When compared to the 4.6.x releases, the directory structure has changed and all of the DLLs have been moved to a subdirectory instead of the root. There was a thread that described copying the QtCore and QtGui DLLs to the root directory, but when I tried it this weekend on the newest release it failed with the same error message.

Phil, do you have any thoughts on this?

Michael Collins <michaelcollins at ivorycity.com> wrote:

>So I just upgraded my pyqt this weekend to 4.7.3-1 under Python 3.1.
>It seems as though there is an issue loading the QtCore,QtGui,etc
>DLL's post-install. I did uninstall the old version and the problem
>The Python exception thrown is:
>DLL Load Failed: The specified procedure could not be found.
>I've upgraded these packages before without issue, so my feeling is
>that something is different with this release.
>PyQt mailing list    PyQt at riverbankcomputing.com

More information about the PyQt mailing list