[PyQt] DLL Problem with PyQt-Py3.1-gpl-4.7.3-1.exe

Phil Thompson phil at riverbankcomputing.com
Mon Apr 19 22:22:20 BST 2010

On Mon, 19 Apr 2010 14:05:04 -0700, Glenn Linderman <v+python at g.nevcal.com>
> On 4/19/2010 9:20 AM, Phil Thompson wrote:
>> On Mon, 19 Apr 2010 09:00:54 -0700, Scott
Ballard<scott at scottballard.net>
>> wrote:
>>> I noticed this issue when I've installed the 4.7.x releases under
>>> 2.6. When compared to the 4.6.x releases, the directory structure has
>>> changed and all of the DLLs have been moved to a subdirectory instead
>>> the root. There was a thread that described copying the QtCore and
>>> DLLs to the root directory, but when I tried it this weekend on the
>> newest
>>> release it failed with the same error message.
>>> Phil, do you have any thoughts on this?
>> No - it works fine for me and I test each installer on a clean system.
>> I don't test a non-admin install.
>> Phil
> I just got the same issue, Python 3.1, PyQt 4.7.3, Windows 7
> My process was to uninstall PyQt 4.7.2 and immediately thereafter, 
> install PyQt 4.7.3
> Programs that worked before, now produce
> ImportError: DLL load failed: The specified procedure could not be found.
> I am an administrator, and the installer caused Windows to ask me for 
> permissions to install.
> Anyone have any suggestions for how to fix this?  Does one have to 
> reinstall Windows, to get a clean system, per Phil's comment?  If so, 
> that'll sure slow down my rate of upgrades for PyQt -- it takes weeks to 
> get all the software reinstalled on my system.

The source code differences between 4.7.2 and 4.7.3 were very small, and
there were no changes to the installer scripts.

The only difference with the binary was that it was linked against Python
3.1.2 rather than 3.1.1.


More information about the PyQt mailing list