[PyQt] Error building PyQt 4.8.1 as universal on OS X 10.5.8

David Aguilar davvid at gmail.com
Tue Dec 28 02:11:02 GMT 2010

On Fri, Dec 17, 2010 at 12:48 PM, Brian Zambrano <brianz at gmail.com> wrote:
> Building a universal version of my commercial PyQt has worked for me in the
> past with these steps:
> sip:
> $ python configure.py --universal
> $ make && sudo make install
> PyQt:
> $ python configure.py --confirm-license
> $ make && sudo make install
> I just upgraded to Qt 4.7, and am trying to build PyQt 4.8.1 with sip
> 4.11.2.  I'm on a 32-bit Intel mac mini with OS X 10.5.8.
> It looks like a symbol is missing, but I'm not sure if that is from Qt or
> PyQt:
> ld warning: in /Library/Frameworks/QtCore.framework/QtCore, missing required
> architecture
> ppc in file
> ....snip

It looks like the "Cocoa: Mac binary package for Mac OS X 10.5 - 10.6
(32-bit and 64-bit)"
does not support the 'ppc' architecture.

I ran into this same problem.

Now, if you were to try and build PyQt you would later run into a
different problem because Python is 32bit and only 32bit on leopard.
I've been dealing with this because I'm packaging git-cola for OS X

I've accepted that Leopard means Intel 32bit only.  I've posted a PyQt
4.8.1 installer online for use with  qt-mac-opensource-4.7.1.dmg.


If anyone would be kind enough to post an equivalent snow leopard
build which uses a 64bit Python built against that same .dmg then I
would greatly appreciate it.  Right now I had to upload my own build
of Qt for snow leopard, which I want to avoid doing.

Ideally, it would be really nice if we could coordinate and have PyQt
installers for the main OS X flavors.  This might be a good place to
coordinate such a thing.

In the meanwhile -- are you looking for a great git GUI built with PyQt?

(this site still hasn't been updated to mention the OS X installers so
if you're on a mac you should visit the google code link to download

More information about the PyQt mailing list