[PyQt] [ubuntu 9.10] compiling pyqt4

David Wolfe dwolfe at fifthsally.com
Sat Feb 20 10:56:27 GMT 2010

On 2/19/2010 9:56 AM, David Wolfe wrote:
> On 2/6/2010 8:19 PM, Michael musset wrote:
>> hi, here is what i get after compiling :
>> /usr/bin/ld: cannot find -lqpycore
>> collect2: ld returned 1 exit status
>> make[1]: *** [QtCore.so] Error 1
>> make[1]: Leaving directory
>> `/home/micka/PyQt-x11-gpl-snapshot-4.7.1-c591dc61687c/QtCore'
>> make: *** [install] Error 2
> I got this same error when compiling on a RHEL 5.2 machine. I knew it
> had multiple CPUs, but I wasn't sure how many, so I boldy tried
> compiling with:
> make -j8
> That seems to have been the cause of the problem. Removing the '-j8'
> allowed me to compile, anyway. YMMV...

Correction: actually, what I initially tried was:

   make -j8 install

I just redid this using:

   make install

(no '-j8') and got the same error.  The only way I could get around it
was to do it in two steps:

   make install

I'm doing a 'local' install, so there's no need to be root.  I thought I
could just type 'make install' without doing a 'make' first, but this
seems not to be the case, at least for me (stock RHEL 5.2, Qt 4.6.2,

More information about the PyQt mailing list