[PyQt] nmake fatal error while compiling SIP - voidptr.c: error C2039

Johanna johanna.royer at gmail.com
Mon May 2 10:53:14 BST 2011


I am trying to compile SIP since a few days in order to install PyQt.
I can't find lead on the web so I thought I'd better ask for help here.

I unzipped the latest sip archive (4.12.1)and run the configure command.
Then when I tried to run nmake it gives me the following error :

.\voidptr.c(513) : error C2039: 'obj' : is not a member of 'bufferinfo'
D:\ProgramFiles\Python26\include\object.h(164) : see declaration of
Generating Code...
NMAKE : fatal error U1077: '"D:\ProgramFiles\Microsoft Visual Studio
9.0\VC\bin\cl.EXE"' : return code '0x2'
NMAKE : fatal error U1077: '"D:\ProgramFiles\Microsoft Visual Studio
9.0\VC\bin\nmake.exe"' : return code '0x2'

The declaration of bufferinfo in object.h is the following :

typedef struct bufferinfo {
    void *buf;
        Py_ssize_t len;
        Py_ssize_t itemsize;  /* This is Py_ssize_t so it can be
                                 pointed to by strides in simple case.*/
        int readonly;
        int ndim;
        char *format;
        Py_ssize_t *shape;
        Py_ssize_t *strides;
        Py_ssize_t *suboffsets;
        void *internal;
} Py_buffer;

And the code at line 513 of voidptr.c is :

PyErr_Format(PyExc_TypeError, "'%s' must have an item size of 1",

I am on windows XP 64bits, with Python 2.6 and visual studio 2008 (I run the
commands from visual studio
command prompt).

Thank you for you consideration.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20110502/33802714/attachment.html>

More information about the PyQt mailing list