[PyQt] newbie installing under OpenBSD

Alan Corey alan01346 at gmail.com
Sat Dec 22 05:26:53 GMT 2012

I'm trying to install PyQt-x11-gpl-4.9.6 from a freshly downloaded
tarball.  I have sip-4.14.2 installed, Python 2.7.1p9 from OpenBSD
qt4-4.7.3p0 also from OpenBSD ports.

Following the directions in the README, when I do:
python2.7 configure.py --verbose
where I extracted in /usr/src/misc/pyqt4/PyQt-x11-gpl-4.9.6
I get messages like:
qtdirs.cpp:1:28: error: QCoreApplication: No such file or directory
qtdirs.cpp:2:17: error: QFile: No such file or directory
qtdirs.cpp:3:24: error: QLibraryInfo: No such file or directory
qtdirs.cpp:4:23: error: QTextStream: No such file or directory
qtdirs.cpp: In function 'int main(int, char**)':
qtdirs.cpp:16: error: 'QCoreApplication' was not declared in this scope

And a whole bunch more.  If this were C I'd say I need to use a -I to
include a path because all these files it isn't finding are in
/usr/local/include/X11/qt4/QtCore.  There aren't any spaces in the
path, and I tried
setenv PYTHONPATH "/usr/local/include/X11/qt4/QtCore" but it didn't help.

I also tried putting a -I/usr/local/include/X11/qt4/QtCore in the
INCPATH in the Makefile.

I don't know much of anything about Python or QT, I'm just trying to
get the qt-gui in gnuradio working.  I think I'm missing something
pretty basic but Googling didn't help much.

Thanks for any help,

  Alan, ab1jx

Credit is the root of all evil.  - AB1JX

More information about the PyQt mailing list