[PyQt] PyQt v4.10.1 install Error on Mac OS X

Melton Low (devl) softw.devl at gmail.com
Tue Apr 23 05:26:52 BST 2013

+1 Got the same error when using configure-ng.py.  Worked fine with old 

I initially got the following error if I don't specify the location of 
the sip binary located within the python3.3 framework bin folder. The 
location is in my $PATH.  Here is the output:

bigbook:PyQt-mac-gpl-snapshot-4.10.2-e93e243169f6 melton$ python3.3 
configure-ng.py --confirm-license
Querying qmake about your Qt installation...
Determining the details of your Qt installation...
This is the GPL version of PyQt snapshot-4.10.2-e93e243169f6 (licensed under
the GNU General Public License) for Python 3.3.1 on darwin.
Found the license file pyqt-gpl.sip.
/bin/sh: ./sip: is a directory
Error: './sip -V' did not generate any output.
bigbook:PyQt-mac-gpl-snapshot-4.10.2-e93e243169f6 melton$

Hope this helps.

My configuration is:

OS X 10.8.3
Xcode 4.6.2
Qt 5.0.2
Sip 4.14.6
PyQt 4.10.2 snapshot e93e243169f6


jrosslist at outlook.com wrote:
> python3 configure-ng.py --sip /Library/Frameworks/Python.framework/Versions/3.3/bin/sip
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20130422/b8890d7a/attachment.html>

More information about the PyQt mailing list