[PyQt] pyqtdeploy v0.6 ImportError on module in Other Packages

lloyd konneker bootch at nc.rr.com
Tue Sep 16 20:31:01 BST 2014

I upgraded to pyqtdeploy v0.6.
On my application that previously pyqtdeployed fine, when I run my app I 

Traceback (most recent call last):
   File "Pensool.py", line 5, in <module>
   File "bootstrap.py", line 2237, in _find_and_load
   File "bootstrap.py", line 2226, in _find_and_load_unlocked
   File "bootstrap.py", line 1191, in _load_unlocked
   File "bootstrap.py", line 1161, in _load_backward_compatible
   File "application.py", line 10, in <module>
   File "bootstrap.py", line 2237, in _find_and_load
   File "bootstrap.py", line 2212, in _find_and_load_unlocked
   File "bootstrap.py", line 321, in _call_with_frames_removed
   File "bootstrap.py", line 2237, in _find_and_load
   File "bootstrap.py", line 2224, in _find_and_load_unlocked
ImportError: No module named 'documentStyle'

This is early in my app, just after importing PyQt modules.  ( 'from 
documentStyle.styleSheetCascadion import StyleSheetCascadion' ) When I 
rearranged the order of imports, later it failed to import a different 
module in a different package in 'Other Packages.'

That is a module in a package in 'Other Packages' in 
/usr/local/lib/python3.4/dist-packages, one of my packages that is 
installed locally.  The console log showed that it was frozen, and make 
succeeded.  .../build/resources/dist-packages/documentStyle exists and 
includes __init__.pyo and subpackages and modules and so forth.

I tried to recreate my old .pdy but maybe I missed something.  I will 
try to debug it myself or reduce it to a minimal example.

Ubuntu 14.04
Qt 5.2.1
PyQt 5.3
SIP 4.16.1
pyqtdeploy 0.6 installed using pip3
(That seems like a hodgepodge,  I'll upgrade.)

More information about the PyQt mailing list