[PyQt] pyqtdeploy building demo problem with NDK

Ronald Petit elronaldpetit at gmail.com
Thu Aug 2 14:06:24 BST 2018

Thanks for your answers Phil.

Now, targeting my host system, I'm getting "Unable to unpack
qt-everywhere-src-5.11.0.tar.xz", I tried to unpack it myself, and takes
like a minute just to open the package manager, is there a way to tell
pyqtdeploy-sysroot to use an already extracted folder?.

In the verbose output it says "unknown archive format" but I was able to
extract it by myself, I also tried redownloading it, but seems to be too

El jue., 2 ago. 2018 a las 4:22, Phil Thompson (<phil at riverbankcomputing.com>)

> On 1 Aug 2018, at 11:45 pm, Ronald Petit <elronaldpetit at gmail.com> wrote:
> >
> > I build the OpenSSL on my host computer (linux 64), and seems like
> there's a step where you have to build the dependencies, and that step
> fails over on the pyqtdeploy when targeting android.
> >
> > I gave up on this, as I can use QtCreator to build APKs, but I still
> need to get PyQt code coverted to Qt standard C++, is pyqtdeploy capable of
> that?, in the case of a affirmative answer, I just need to deploy as I'm
> doing but targeting my host system?
> That's the whole point of pyqtdeploy...
> http://pyqt.sourceforge.net/Docs/pyqtdeploy/overview.html
> Phil
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.riverbankcomputing.com/pipermail/pyqt/attachments/20180802/085c17c2/attachment.html>

More information about the PyQt mailing list