[PyQt] pyqtdeploy building demo problem with NDK

Phil Thompson phil at riverbankcomputing.com
Fri Aug 3 08:14:15 BST 2018

On 3 Aug 2018, at 6:04 am, Ronald Petit <elronaldpetit at gmail.com> wrote:
> Okay Phil, I'm still here, sorry if I'm bothering too much, but as more as I read, seems like pyqtdeploy is my only option to convert PyQt5 into Qt C++ code.
> Now, I setup sysroot.json to use my existing Qt installation, then, It was complaining about Python, as I tried to use Python-3.7.0.tar.xz, and got the same error as on Qt because it is an xz, however, I downloaded Python-3.7.0.tgz, the pyqtdeploy was able to extract that one (Still not too much clues about why Python cannot extract .xz files, the error message was "Unknown file format", I built my own Python (Python 3.7.0), so I'm thinkking I did something wrong there.

As I said, you have to have the xz support available when building Python (the xz-devel package on Red Hat).

> Now the pyqtdeploy is complaining when building Python, it says:
> Python/sysmodule.c: In function ‘_PySys_BeginInit’:
> Python/sysmodule.c:2303:60: error: ‘_PYTHONFRAMEWORK’ undeclared (first use in this function)
>      SET_SYS_FROM_STRING("_framework", PyUnicode_FromString(_PYTHONFRAMEWORK));
> Then a bunch of notes and the final error of make returning non-zero exit status. No clue about this on google, any other hint?

pyqtdeploy v2.1 does not support Python v3.7.0. v2.2 will. The latest version supported by v2.1 is v3.6.4.


More information about the PyQt mailing list