[PyQt] Crosscomping sip with a sip.cfg file

Philip Balister philip at balister.org
Sat Sep 8 12:25:24 BST 2018

On 09/08/2018 04:39 AM, Phil Thompson wrote:
> On 6 Sep 2018, at 8:10 pm, Philip Balister <philip at balister.org> wrote:
>> I'm updating the recipe in OpenEmbedded to the recent release. I am
>> running into an issue where the python parts are ending up in the build
>> sysroot, not the image. So the packaging doesn't pick up the python
>> parts of sip.
>> I create a sip config with required paths, the line I see in the
>> generated sip.cfg is:
>> sip_module_dir =
>> /home/balister/opensdr/sdr-build-master-qemu/build/tmp-glibc/work/core2-64-oe-linux/sip/4.19.12-r0/image//usr/lib/python%(py_major).%(py_minor)/site-packages
>> which is where I want to the the sip module end up, but after config,
>> compile etc I see this in sipconfig.py:
>> 'sip_module_dir':
>> '/home/balister/opensdr/sdr-build-master-qemu/build/tmp-glibc/work/core2-64-oe-linux/sip/4.19.12-r0/recipe-sysroot/usr/lib/python2.7/site-packages/PyQt5',
>> Which is not where I need the module installed.
>> Any ideas? This has worked in the past.
> Difficult to say without more context. Also I'd suggest you try the current snapshot.

I tried the head of the Hg repo and had the same issue.

In the end, this patch on top of the tarball helps. Still puzzling over
getting PyQt5 going again though.

I'm not sure if this is correct, but the PyQT5 sip.so ends up where I
think it should.


> Phil
-------------- next part --------------
A non-text attachment was scrubbed...
Name: sip.patch
Type: text/x-patch
Size: 600 bytes
Desc: not available
URL: <https://www.riverbankcomputing.com/pipermail/pyqt/attachments/20180908/6534dcd6/attachment.bin>

More information about the PyQt mailing list