[PyQt] Win32 Error with PyQt 5.14.1

Ian Ottoway ian at ottoway.dev
Tue Mar 17 12:30:28 GMT 2020

I ran into this issue as well as asked on here not too long ago, there is a bug in the pyqt-bundle that packages the wrong MS DLLs.  Replace these DLLs in the Qt/bin folder: concrt140, mscvp140, and vcruntime140 with the ones from 5.13.

---- On Mon, 16 Mar 2020 21:23:29 -0500 Doug Bell <dougb at bellz.org> wrote ----


I've run PyQt on an older PC with Windows 10 for a long time.  But after
installing PyQt 5.14.1 on a Python 3.8 32-bit install (using "pip
install PyQt5"), I get the following error when trying to run any PyQt

 ImportError: DLL load failed while importing QtCore: %1 is not a
 valid Win32 application.

Installing PyQt 5.14.0 gives the same result, but it works fine after
installing PyQt 5.13.2, with no other changes.

Any ideas?  Did something change in PyQt 5.14?

PyQt mailing list mailto:PyQt at riverbankcomputing.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.riverbankcomputing.com/pipermail/pyqt/attachments/20200317/a5b6281e/attachment.htm>

More information about the PyQt mailing list