[QScintilla] PyQt Bindings for QScintilla on OS X 10.4 dlopen Problem

Curtis Faith curtis at worldhouse.org
Mon Jul 2 01:24:43 BST 2007

I am in the process of installing Eric 4 on and am stuck on one of  
the steps since it seems that QScintilla's python bindings are not  
setup correctly.

Here are my current versions:

> Python-2.5.1
> qt-mac-opensource-4.3.0
> sip-4.6
> PyQt-mac-gpl-4.2
> QScintilla-1.73-gpl-2.1

I have been working on this for several days. I have run into many  
problems and it is a bit of a whack-a-mole in that everytime I fix  
one problem another pops up, sometimes the same one I faced earlier.  
I have followed the directions explicitly but they are no where near  
sufficient on OS X.

My current problem is getting the PyQt bindings for QScintilla  
working. I have had these working before but then had the problem I  
outline below (currently I can import qVersion fine and don't get a  
Bus Error).

I do get an error saying that I need to install QScintilla because  
the python install script can't find the library. I isolated this  
down to the following interpreter snippet.

Python 2.5.1 (r251:54869, Apr 18 2007, 22:08:04)
[GCC 4.0.1 (Apple Computer, Inc. build 5367)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
 >>> from PyQt4 import Qsci
Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.5/ 
lib/python2.5/site-packages/PyQt4/Qsci.so, 2): Library not loaded:  
   Referenced from: /Library/Frameworks/Python.framework/Versions/2.5/ 
   Reason: image not found

I have tried copying the libqscintilla2.2.dylib file various places  
to see if I can at least get past this error but can't seem to. I am  
just now returning to the Mac from a long hiatus in the hell of  
Windows and haven't used FreeBSD in years so I have no idea how  
Python on darwin loads dynamic libraries which doesn't help.

Does anyone have any ideas what might be going on?

- Curtis

The following is an earlier message I sent to the eric mailing list:
> From: Curtis Faith <curtis at worldhouse.org>
> Date: June 30, 2007 6:47:05 PM GMT-03:00
> To: eric at riverbankcomputing.com
> Subject: Bus Error running eric's install.py at qVersion() call
> I'm having one hell of a time installing Eric4 on a brand new Intel  
> MacBook running OS X 10.4.10
> This is my fourth failed attempt at installing eric in the last  
> year, and the first one on a Unix-based OS. If I can't get this to  
> work soon, I will pick another IDE, I have spent about a solid day  
> on this on this go around and am stuck on what should be the last  
> easy step.
> I have everything installed except the last step, and I have double- 
> checked the order three times. I installed the latest versions of  
> everything including:
> Python-2.5.1
> qt-mac-opensource-4.3.0
> sip-4.6
> PyQt-mac-gpl-4.2
> QScintilla-1.73-gpl-2.1
> The command:
> sudo python install.py
> results in:
> Bus Error
> I installed a new version of Python 2.5.1 and modified it to  
> include the debugging symbols and tried running gdb and get:
> curtis-faiths-computer:~/Desktop/eric4-4.0.0 curtis$ gdb python  
> install.py
> GNU gdb 6.3.50-20050815 (Apple version gdb-573) (Fri Oct 20  
> 15:50:43 GMT 2006)
> Copyright 2004 Free Software Foundation, Inc.
> GDB is free software, covered by the GNU General Public License,  
> and you are
> welcome to change it and/or distribute copies of it under certain  
> conditions.
> Type "show copying" to see the conditions.
> There is absolutely no warranty for GDB.  Type "show warranty" for  
> details.
> This GDB was configured as "i386-apple-darwin"...Reading symbols  
> for shared libraries .. done
> "/Users/curtis/Desktop/eric4-4.0.0/install.py" is not a core dump:  
> File format not recognized
> (gdb) run
> Starting program: /Library/Frameworks/Python.framework/Versions/2.5/ 
> bin/python
> Reading symbols for shared libraries . done
> Program received signal SIGTRAP, Trace/breakpoint trap.
> 0x8fe01010 in __dyld__dyld_start ()
> (gdb)
> The bt command results in only the single entry for  
> __dyld__dyld_start ()
> This appears to be the call to dynamically load a shared library on  
> Darwin as best I can tell.
> I placed print statements inside install.py to find out that the  
> following call:
> 	qtMajor = int(qVersion().split('.')[0])
> is causing the Bus Error. Specifically the call to "qVersion()".  
> This tells me that there is probably something wrong with the PyQt  
> installation or SIP but I have no idea what it might be or how to  
> proceed.
> Does anyone have any idea how I can figure out what might be  
> causing this problem?
> - Curtis

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.riverbankcomputing.com/pipermail/qscintilla/attachments/20070702/77191f0e/attachment.html

More information about the QScintilla mailing list