[PyKDE] PyKDE and KDE head(cvs)

Evgeny Zemlerub evgeny at eplication.com
Tue Jul 16 15:53:01 BST 2002


I tried to build latest Sip/ PyQT/ PyKDE on Debian SID with KDE from 

It went pretty fine till I arrived to compile PyKDE. Duiring build it was 
missing includes here and there, but it waseasily fixed by adding thier
location to include path in makefiles.

It worked fine till i arrived to kfile.  After i added include pathes  (
-I./ -I/usr/include/g++-3/ -I/opt/kde3/include/kio 
-I/usr/local/src/PyKDE-3.2.4/kio -I/usr/local/src/PyKDE-3.2.4/extraH/kde300/)

it gave me following error :
In file included from kfilecmodule.cpp:57:
sipkfileKAppTreeListItem.h:51: parse error before `{'
sipkfileKAppTreeListItem.h:54: parse error before `*'
sipkfileKAppTreeListItem.h:55: parse error before `const'
sipkfileKAppTreeListItem.h:56: destructors must be member functions
sipkfileKAppTreeListItem.h:63: non-member function `enforceSortOrder()' cannot 
have `const' method qualifier
sipkfileKAppTreeListItem.h:65: non-member function `rtti()' cannot have 
`const' method qualifier
sipkfileKAppTreeListItem.h:69: non-member function `acceptDrop(const 
QMimeSource *)' cannot have `const' method qualifier
sipkfileKAppTreeListItem.h:81: non-member function `compare(QListViewItem *, 
int, bool)' cannot have `const' method qualifier
sipkfileKAppTreeListItem.h:82: non-member function `key(int, bool)' cannot 
have `const' method qualifier
sipkfileKAppTreeListItem.h:83: non-member function `pixmap(int)' cannot have 
`const' method qualifier
sipkfileKAppTreeListItem.h:85: non-member function `text(int)' cannot have 
`const' method qualifier
sipkfileKAppTreeListItem.h:87: non-member function `width(const QFontMetrics 
&, const QListView *, int)' cannot have `const' method qualifier
sipkfileKAppTreeListItem.h:113: parse error before `private'
sipkfileKAppTreeListItem.h:115: syntax error before `&'
sipkfileKAppTreeListItem.h:118: parse error before `}'
sipkfileKAppTreeListItem.h:120: syntax error before `*'
In file included from kfilecmodule.cpp:58:
sipkfileKApplicationTree.h:55: base class `KApplicationTree' has incomplete 
make: *** [kfilecmodule.lo] Error 1

Is it something known or just bad case of incompability between kde3.0 and kde 
head (3.06 aka 3.1alpha) ?


More information about the PyQt mailing list