[PyKDE] Qt 3.0.4 and PyQt-3.2.4 install trouble

Donovan Rebbechi elflord at andromeda.rutgers.edu
Tue Jun 11 05:47:00 BST 2002

On Sat, 8 Jun 2002, Hans-Peter Jansen wrote:

> Hi,
> just tried to install $subject. While building Qt and PyQt was successful,
> PyQt throws this error message on make install:
> /bin/sh ../mkinstalldirs /usr/lib/python2.1/site-packages
>  /usr/bin/install -c -m 644 qt.py /usr/lib/python2.1/site-packages/qt.py
> make  install-data-hook
> make[3]: Entering directory `/home/hp/Downloads/qt/PyQt-3.2.4/qt'
> (cd /tmp; PYTHONPATH=/usr/lib/python2.1/site-packages:/usr/lib/python2.1/site-packages
> /usr/bin/python -c "import qt")
> Traceback (most recent call last):
>   File "<string>", line 1, in ?
>   File "/usr/lib/python2.1/site-packages/qt.py", line 49, in ?
>     import libqtc
> ImportError: /usr/lib/python2.1/site-packages/libqtcmodule.so: undefined symbol:
> static_QUType_ptr
> while objdump says, it exists:
> objdump -t /usr/lib/python2.1/site-packages/libqtcmodule.so | grep static_QUType_ptr
> 00000000         *UND*  00000000              static_QUType_ptr
> I haven't seen this one before. Any ideas? To be sure, I removed all sip and qt
> rudiments from site-packages and tried again, with the same results.
> I'm puzzled :-(

gingercat% /usr/gcc-3.1/bin/c++filt  static_QUType_ptr

Oddly enough, this only demangles when I use gcc 3.1. Perhaps you're
trying to link libraries built by different C++ compilers ?

Anyway, looks like you've got a compatibility issue of sorts, perhaps a
shared library conflict, or something.

I'd try running ldd and looking for obvious red flags (such as attempts
to link to two different versions of the same library) in the output.


More information about the PyQt mailing list