[PyKDE] Qt 3.0.4 and PyQt-3.2.4 install trouble

Hans-Peter Jansen hpj at urpla.net
Tue Jun 11 12:57:00 BST 2002

Hi Joe, hi Donovan,

thanks for your answers. They pushed me in the right direction.
Let me resume, that, if you get strange build errors like mine
or Joe's, clean up your environment:

check $QTDIR for root and your build account
> 1)Delete all PyQt and sip files from /usr/lib/python2.1/site-packages/ 
> including eric/ .
> 2)If you have ever installed a version of sip less than 3.1 there will be 
> files in /usr/local/lib and /usr/local/include , get rid of these, there is 
> also a file in /usr/local/bin , I got rid of this as well, but it is not 
> mentioned in the sip README file.
> 3)The PyQt README file mentions version prior to 2.0, but I don't know where 
> they installed.
> 4)chmod 000 the old version of Qt that was causing problems. Remember that 
> software using it wont work.
> 5)Delete the source trees of PyQt and sip, assuming you built in the source 
> tree, and create them again from the original .tar.gz files.
> 6)Start all over again but this time using ./configure --with-qt-dir=$QTDIR ; 
> for both sip and PyQT.

I've done 1, 2, 5 before. 3 and 4 seems not to matter here.

6 was the one, which solved $subject for me, although 
ldd /usr/lib/python2.1/site-packages/libqtcmodule.so
linked to the correct version via some symlink levels:

libqt-mt.so.2 => /usr/lib/libqt-mt.so.2
/usr/lib/libqt-mt.so.2 -> qt2/lib/libqt-mt.so.2
/usr/lib/qt2/lib/libqt-mt.so.2 -> libqt-mt.so.2.3.1
-rwxr-xr-x    1 root     root      5567532 24. Sep 2001

Self compiled KDE 2.2.2 is running fine with it, btw...

> I doubt all of this was necessary, but PyQt takes such a long time to compile 
> I was taking no chances.
> I hope this is usefull to you.

Indeed, it was. Thanks again.

> It would be good if someone could tell me at what point Qt is linked to, and 
> how it is decided which Qt to link to? I notice that make install ; uses 
> libtool .

I assume, gcc and/or build tools gets confused somehow with deeply symlinked libs.

Some questions remain: PyQt links against /usr/lib/qt3/lib/libqt-mt.so.3
What are the tradeoffs of the multithread option. Should I rebuild without?
Is this the source of the "Mutex destroy failure: Device or resource busy"
errors with examples/desktop.py?

I tried to port examples/table.py, but besides of including qttable, it
seem to be QTableView is missing, isn't it?


More information about the PyQt mailing list