[PyKDE] PyQt-snapshot on Qt Embedded

gvermeul at grenoble.cnrs.fr gvermeul at grenoble.cnrs.fr
Sat Jun 15 09:31:00 BST 2002


I tried to install PyQt-snapshot-20020614 on Qt-Embedded-3.0.4 (QtE). Here you
have my experiences (LinuxFromScratch-3.3, Python-2.2.1 without special
configuration options, gcc-2.95.3):

(1) The following environment settings are necessary

export QTDIR=/usr/lib/qt3
export QMAKESPEC=qws/linux-x86-g++

(1) Qt-Embedded disables runtime type information, so

CXXFLAGS="-fno-rtti" ./configure --prefix=/usr

builds libsip for Qt Embedded (will be resolved with your build system).

(2) build.py is not working for QtE, so I changed build.py to accept
a -e option to force sip generating for Qt (the qmake generated makefiles
select between X11 and Embedded by -DQWS). See attached patch.

(3) had to adapt qnamespace.sip and qprocess.sip, see patch

(4) "python aclock.py -qws" worked, but the other examples did not work
because they attempted to set the Frame Buffer device to non-existent modes.
Trolltech's corresponding C++ examples are OK.
Fiddling around, I discovered that adding
"print sys.argv"
to aclock.py caused a segmentation error. This does not occur with PyQt-3.2.4
under X11.


This message was sent using Endymion MailMan.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PyQt-QWS.patch.bz2
Type: application/octet-stream
Size: 1096 bytes
Desc: not available
Url : http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20020615/3411e498/PyQt-QWS.patch.obj

More information about the PyQt mailing list