[PyKDE] eric3 and x86_64

Hans-Peter Jansen hpj at urpla.net
Sun Jun 27 01:01:06 BST 2004

On Saturday 26 June 2004 21:29, Rick L Vinyard Jr wrote:
> Hello.
> I've been trying to get some (any) version of eric3 installed on a
> gentoo amd64 box. I've completely rebuilt all dependant libraries,
> just in case that was an issue. I've also tried different
> combinations of the PyQt (3.11, 3.12), sip (4.0.rc2, 4.0rc4, 4.0)
> and qscintilla (1.54, 1.60) libraries to no avail.
> Despite changing libraries, behavior seems consistent. All 3.4+
> (3.4.1, 3.4.2, snapshot-20040622) versions seem to die after the
> splash screen with a segfault. All versions prior to 3.4 (3.3.x,
> 3.2.x) make it past the splash screen, the main window is displayed
> briefly (about 1 second) and terminates with a bus error.
> Any suggestions?

Eric is definitely not the offender here, as I ran some of the above 
combinations on my SuSE 9.1-x86_64 system properly. The last x86_64 
issue, I know was fixed by Phil around sip 4.0rc2/3.12pre time. Did 
you supplied proper build arguments to the whole set, aka. lib64 vs. 
lib issues, and the like?

Providing a backtrace would be helpful, probably from a debug build, 
as well as trying some example3 scripts..


More information about the PyQt mailing list