[PyKDE] Trying to get eric3 working

Jack Orenstein jao at geophile.com
Sun Nov 6 18:04:05 GMT 2005

I'm trying to get eric3 working on an FC4 system, but seem to be
off in the weeds.

- I have qt-3.3.4-14 installed.

- I tried installing sip, PyQt and qscintilla via yum, but then
when running "python install.py" for eric:

     [root at localhost eric-3.7.2]# python install.py
     Sorry, please install QScintilla and/or reinstall
     PyQt with QScintilla support.
     Error: No module named qtext

- I then saw the eric README which specified installation order.
Installing PyQt:

     An internal error occured.  Please report all the output from the
     program, including the following traceback, to
     support at riverbankcomputing.co.uk.

     Traceback (most recent call last):
       File "configure.py", line 1043, in ?
       File "configure.py", line 937, in main
         sipconfig.error("This version of PyQt requires SIP v%s or later"
       % sipcfg.version_to_strin g(minv))
       File "/usr/lib/python2.4/site-packages/sipconfig.py", line 169, in
         raise AttributeError, "\"%s\" is not a valid configuration value
     or user option" % name
     AttributeError: "version_to_string" is not a valid configuration
     value or user option

- I then backed up further and tried building sip, but it needs to know
QTDIR. I tried a couple of different guesses, but each time:

     Error: This version of Qt seems to use tmake but the TMAKEPATH
     environment is not set.

This seems far more broken than it should be. Can someone set me on the
right path?


More information about the PyQt mailing list