[PyKDE] Trying to get eric3 working

Jack Orenstein jao at geophile.com
Sun Nov 6 21:09:10 GMT 2005

Michael Andrews wrote:
 > On Sun, 2005-11-06 at 13:04 -0500, Jack Orenstein wrote:
 >>- I then backed up further and tried building sip, but it needs to know
 >>QTDIR. I tried a couple of different guesses, but each time:
 >>     Error: This version of Qt seems to use tmake but the TMAKEPATH
 >>     environment is not set.
 >>This seems far more broken than it should be. Can someone set me on the
 >>right path?
 > Here's how I did it with FC4.
 > Installed the packages: qt, qt-devel, qscintilla, and qscintilla-devel.


 > Downloaded the sip and PyQt source RPMS.
 > Rebuild and installed sip from the FC4 .src.rpm w/ rpmbuild --rebuild

OK. I got sip-4.3.1.

 > Rebuild and installed PyQt from the FC4 .src.rpm w/ rpmbuild --rebuild

Not OK:

[root at localhost software]# rpmbuild --rebuild PyQt-3.15-1.src.rpm
Installing PyQt-3.15-1.src.rpm
error: Failed build dependencies:
         sip-devel >= 4.3.1 is needed by PyQt-3.15-1.i386

Note that this is the version I built, and the output from
that build indicates that the version number is 4.3.1.


More information about the PyQt mailing list