[PyKDE] Questions about PyKDE

Jim Bublitz jbublitz at nwinternet.com
Tue Apr 4 19:14:53 BST 2006

On Tuesday 04 April 2006 10:43, Michal Krenek wrote:
> Hello,
> In my distribution (Arch Linux) PyKDE is not included in kdebindinbgs
> package (because of some build problems in the past). So I have tried to
> build it myself. But there goes first question - should I use PyKDE
> snapshot package from here or PyKDE included in kdebindings 3.5.2? Which
> version of PyKDE is newer? How are snapshots from here related to PyKDE
> included in kdebindings?
> Anyway, I have tried to build PyKDE-snapshot20060122.tar.gz first, but
> failed with this error:
> Creating top level Makefile...
> Creating pykdeconfig.py...
> make[1]: Entering directory
> `/home/mikos/temp/abs/pykde/src/PyKDE-snapshot20060122/dcop'
> g++ -c -Wno-deprecated-declarations -pipe -fPIC -march=i686 -O2 -pipe -Wall
> -I/opt/kde/include -I/usr/include/python2.4 -I/opt/qt/include
> -I/opt/qt/mkspecs/linux-g++ -I/usr/X11R6/include -o sipdcoppart0.o
> sipdcoppart0.cpp
> sip/dcop/dcopobject.sip: In function 'int
> convertTo_QPtrList_0200DCOPObject(PyObject*, void**, int*, PyObject*)':
> sip/dcop/dcopobject.sip:137: error: too many arguments to function
> sip/dcop/dcopobject.sip: In function 'PyObject*
> convertFrom_QPtrList_0200DCOPObject(void*, PyObject*)':
> sip/dcop/dcopobject.sip:112: error: 'sipMapCppToSelf' was not declared in
> this scope
> sip/dcop/dcopclient.sip: In function 'int
> convertTo_QValueList_0200QCString(PyObject*, void**, int*, PyObject*)':
> sip/dcop/dcopclient.sip:231: error: 'sipForceConvertToTransfer_QCString'
> was not declared in this scope
> make[1]: *** [sipdcoppart0.o] Error 1
> make[1]: Leaving directory
> `/home/mikos/temp/abs/pykde/src/PyKDE-snapshot20060122/dcop'
> make: *** [all] Error 2
> Do you know what is wrong? I am using gcc 4.0.3.
> Then I have tried to build PyKDE from kdebindings-3.5.2 (only PyKDE, not
> other things from kdebindings - I have kdebindings installed). I have
> patched it with configure.py.diff patch from Gentoo (without this patch, it
> is giving me TypeError: __init__() got an unexpected keyword argument
> 'builddir'). But it also failed:
> An internal error occured.  Please report all output from the program,
> including the following traceback, to the PyKDE mailing list
> Traceback (most recent call last):
>   File "configure.py", line 852, in ?
>     main(sys.argv)
>   File "configure.py", line 824, in main
>     generate_code (module, pykde_imports [module], extra_lib = module)
>   File "configure.py", line 676, in generate_code
>     makefile.generate()
>   File "/usr/lib/python2.4/site-packages/sipconfig.py", line 939, in
> generate self.ready()
>   File "/usr/lib/python2.4/site-packages/sipconfig.py", line 934, in ready
>     self.finalise()
>   File "/usr/lib/python2.4/site-packages/sipconfig.py", line 1546, in
> finalise ModuleMakefile.finalise(self)
>   File "/usr/lib/python2.4/site-packages/sipconfig.py", line 1348, in
> finalise Makefile.finalise(self)
>   File "/usr/lib/python2.4/site-packages/sipconfig.py", line 594, in
> finalise qtincdir = self.optional_list("INCDIR_QT")
>   File "/usr/lib/python2.4/site-packages/sipconfig.py", line 745, in
> optional_list
>     return self.__dict__[name].as_list()
> KeyError: 'INCDIR_QT'
> make: *** No targets specified and no makefile found.  Stop.
> What am I doing wrong?

It looks like you're using a sip version that's newer than what the tarball or 
kde-bindings packages expect. The tarball errors look like some sip function 
calls that may have been obsoleted in sip 4.4.x; the kde-bindings errors 
appear to be from earlier sip changes (4.3?) in how config files are 

I'm way behind in updating PyKDE to the latest sip, but am hoping to get 
something out soon.  


More information about the PyQt mailing list