[PyKDE] Re: Eric3 python shell and debugger don't work for PyQt4

Douglas Andrade dsandrade at gmail.com
Mon Mar 20 10:49:12 GMT 2006

heh, i have this problem too.

Im running the latest snapshots and Archlinux.

On 3/17/06, 张毅 (Izico Chang) <izicochang at gmail.com> wrote:
> Hi,I'm new here.
> I've downloaded all the snapshots from
> http://www.die-offenbachs.de/detlev/snapshots/ and
> http://www.riverbankcomputing.com/Downloads/Snapshots,and the newest
> ones there i've tried are:
> qscintilla-1.65-gpl-snapshot-20060311
> sip-snapshot-20060317
> PyQt-x11-gpl-snapshot-20060314
> PyQt4-gpl-snapshot-20060314
> eric-snapshot-20060123
> Eric3 now work with both PyQt3 and PyQt4 in editor mode.
> But the python shell run commands without any output,both in conole
> and shell subwindow.
> and the Debug don't work too,no any response to my click.
> In my Gentoo box,the native Gentoo packages:
> sip-4.3.2
> PyQt-x11-gpl-3.15.1
> worked well with many Qscintilla and Eric3 versions I've
> downloaded,but they don't work with PyQt4.
> I've seen that Eric3 spawn two python process,one is
> eric3.py,this process worked well in both case,but this one DebugClient.py
> only run well in sip4.3.2,and when in sip-snapshot-20060317, ps -elf
> just show a defunct python process,should i have to debug this long
> program?
> Thanks for anyone who can help me in this,it's not productive for me
> to trace the problem as a newcommer to this field,i need your expert's
> advice to let me use eric3 to develop PyQt4 programs as quickly as
> possible.
> Overall,Eric3 is maybe the best Python IDE i tried by now,but should
> Eric3 have some Vi key bindings? Visual SlickEdit has good Vi key
> binding support,so it's maybe the only IDE i used sometimes(i love its
> refactoring for C++ too),as a long time Vi user,one key point when i
> select one IDE is if it has some kind of Vi key bindings support.

More information about the PyQt mailing list