[PyQt] Problem linking PyQt 4.3.3 on OS X 10.4]

Dylan Trotter trotterdylan at yahoo.ca
Fri Apr 11 01:49:10 BST 2008

Thanks for the tip. I tried working around it using the method you suggested,
but I got unnerving warnings about conflicts due to the flat namespace. I tried
using "-undefined dynamic_lookup" which actually seemed to solve the issue. But
I then had to add /usr/local/Trolltech/Qt-4.3.4/lib to my DYLD_FRAMEWORK_PATH
in order to get it to link properly at runtime. Examining the PyQt .so's with
otool finally allowed me to connect the dots since it indicated that they were
linking against:


I had no idea this installation even existed, but it explained everything. The
configure.py script did correctly identify my /usr/local install of Qt, but it
also added /opt/local/Trolltech/Qt-4.2.1/lib to my framework path on link, so
that's why the link errors. In any case, I think there is something strange
with the configure.py script, but I'm not familiar enough with it to identify
the problem. I suspect it'll be reproducible in similar circumstances.

Hope no one wasted their time on this one!


--- Darryl Wallace <darryl.wallace at prosensus.ca> wrote:

> Hello Dylan,
> I had a similar error with QtOpenGL.so when compiling PyQt4 on the OSX.
> This occured while running 'make' and I had to go into the folder 
> /QtOpenGL and edit the MakeFile.
> I had to find the line that started with LFLAG and add "-flat_namespace 
> -undefined suppress"   at the end (without the quotes).
> Perhaps this will work when the error is on QtCore.so.  I don't remember 
> the cause of this problem, however.
> The tip was found on this blog giving a brief tutorial on building Qt4 
> and PyQt on Mac OSX:
> There is a comment near the bottom by someone named "Dexter" who gives 
> the above solution.
> Did you install Qt4 from the .dmg package?
> Darryl
> Dylan Trotter wrote:
> > I'm getting undefined symbols when I try to compile PyQt on OS X. The 
> > error
> > message is identical to the one mentioned in this thread:
> >
> > http://www.mail-archive.com/pyqt@riverbankcomputing.com/msg11309.html
> >
> > I've tried PyQt 4.3.3 with Qt 4.3.4 and 4.3.3 with no success. Has anyone
> > encountered this and found a solution?
> >
> > Thanks,
> >
> > -dt
> >
> >
> >       __________________________________________________________________
> > Ask a question on any topic and get answers from real people. Go to 
> > Yahoo! Answers and share what you know at http://ca.answers.yahoo.com
> > _______________________________________________
> > PyQt mailing list    PyQt at riverbankcomputing.com
> > http://www.riverbankcomputing.com/mailman/listinfo/pyqt
> >   
> _______________________________________________
> PyQt mailing list    PyQt at riverbankcomputing.com
> http://www.riverbankcomputing.com/mailman/listinfo/pyqt

Be smarter than spam. See how smart SpamGuard is at giving junk email the boot with the All-new Yahoo! Mail.  Click on Options in Mail and switch to New Mail today or register for free at http://mail.yahoo.ca

More information about the PyQt mailing list