[PyQt] PyQt4 and Stackless 2.5.2?

Phil Thompson phil at riverbankcomputing.com
Tue Jul 22 13:45:03 BST 2008

On Tue, 22 Jul 2008 08:32:34 -0400, inhahe <inhahe at gmail.com> wrote:
> Can anyone tell me how to get PyQt4 working with Stackless?
> I found this:
> ___________________________
> Subject:	Re: [PyQt] PyQt4.3 and stackless python 2.5.1 working?Link to
> this message
> From:	Michael Guntsche (mi... at it-loops.com)
> Date:	08/28/2007 04:20:16 PM
> List:	org.kde.pykde
> On Aug 29, 2007, at 0:08, Michael Guntsche wrote:
> Hi list,
> I recently played around a little bit with stackless python and also
> wanted to try it together with PyQt to see how lightweight threading
> works. The problem is that it look like stackless and pyqt4 do not
> like each other very much.
> Ok, answering my own mail here after searching through the stackless
> mail archive. Changing siplib.c like explained here
> http://article.gmane.org/ gmane.comp.python.stackless/2431 gave me a
> working sip and pyqt with stackless python. I have not tested if this
> breaks normal python but I thought I might post an answer to the list
> in case someone else is looking for it.
> Kind regards, Micaehl
> ___________________________
> But the link given is just a blank page now.

The link contains an obvious typo.

> So does anyone know what
> change needs to be made to siplib.c?  Also, would I have to compile
> SIP and PyQt4, or could I just compile SIP and use the PyQt4 Windows
> binaries?  Because I already tried compiling PyQt4....it doesn't work.

The change was made to SIP v4.7.1.


More information about the PyQt mailing list