[PyQt] Snow Leopard

Michael Held michael.held at bc.biol.ethz.ch
Mon Sep 28 10:01:40 BST 2009

hi pyqt,

I had some problems forcing Apples Python to 32 bit. neither
defaults write com.apple.versioner.python Prefer-32-Bit -bool yes
was working.

compiling sip4.9 and PyQt4.6 for Qt4.5.2 worked fine, but importing failed:

 > python -c "from PyQt4 import QtCore"
 > Traceback (most recent call last):
 >   File "<string>", line 1, in <module>
 > ImportError: 
dlopen(/Library/Python/2.6/site-packages/PyQt4/QtCore.so, 2): no 
suitable image found.  Did find:
 >         /Library/Python/2.6/site-packages/PyQt4/QtCore.so: mach-o, 
but wrong architecture

 > arch -i386 python -c "from PyQt4 import QtCore"
worked. unfortunately I could not force Eclipse/PyDev to run Python in 
32bit and therefore auto-completion of PyQt is not working.

is there anything I can do to improve this situation?

best regards

PS: for some strange reasons Python 2.6.2 from Python.org crashes with 
Eclipse3.5/PyDev1.5 (both 32 bit carbon and 64 bit cocoa versions)

More information about the PyQt mailing list