[PyQt] pyqt 4.7+ on mac osx snow leopard

Massimo Di Stefano massimodisasha at yahoo.it
Tue Feb 2 23:58:21 GMT 2010

Hi All,

i'm tring to install pyqt on my snow leopard, until the last week i used :

Qt-4.6 build from source (-cocoa) and pyqt4.6.2 (all worked fine)
for some reason i had to switch to a Qt4-4.6 (dmg installer -64bit) 
and now tring to install pyqt (i tried both  pyqt-4.7 (+sip-4.10) and pyqt-sip-snapshot)

but i'm having this error (for both versions i tried) :

Frameworks/QtCore.framework/Versions/4/Headers -I/usr/include/QtCore -I/Library/Frameworks/QtGui.framework/Versions/4/Headers -I/usr/include/QtGui -I/usr/include -I/usr/local/include -I/System/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -I../../QtCore -I. -I. -F/Library/Frameworks -o qpycore_pyqtpyobject.o qpycore_pyqtpyobject.cpp
g++ -c -pipe -fno-strict-aliasing -O2 -fPIC -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.5 -Wall -W -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Qt4.6/mkspecs/macx-g++ -I. -I/Library/Frameworks/QtCore.framework/Versions/4/Headers -I/usr/include/QtCore -I/Library/Frameworks/QtGui.framework/Versions/4/Headers -I/usr/include/QtGui -I/usr/include -I/usr/local/include -I/System/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -I../../QtCore -I. -I. -F/Library/Frameworks -o qpycore_pyqtsignal.o qpycore_pyqtsignal.cpp
qpycore_pyqtsignal.cpp: In function ‘int qpycore_get_lazy_attr(const sipTypeDef*, PyObject*)’:
qpycore_pyqtsignal.cpp:458: error: ‘const struct _pyqt4QtSignal’ has no member named ‘docstring’
qpycore_pyqtsignal.cpp: At global scope:
qpycore_pyqtsignal.cpp:473: warning: ‘int add_overload(qpycore_pyqtSignal*, const char*, const char*)’ defined but not used
make[2]: *** [qpycore_pyqtsignal.o] Error 1
make[1]: *** [all] Error 2
make: *** [all] Error 2
MacBook-Pro-15-di-Massimo-Di-Stefano:PyQt-mac-gpl-snapshot-4.7.1-08c09018a2d5 sasha$ 

have you any clue on what i'm wrong ?

i used this configure :

python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin \
-e /usr/local/include -v /usr/local/share/sip --arch=x86_64

and pyqt :

python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin --use-arch x86_64



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20100203/706f29ab/attachment-0001.html>

More information about the PyQt mailing list