[PyQt] Displaying . in a tableitem

Protopia pyqt4 at protopia.co.uk
Fri Jul 29 20:24:44 BST 2011

Thanks. I tried looking up ellipsis on the internet and came up with the \U equivalent of the \N below which worked.

I had the ellipsis copied and pasted from Microsoft word into a "" string and that seemed to be the problem.


-----Original Message-----
From: Phil Thompson [mailto:phil at riverbankcomputing.com] 
Sent: 29 July 2011 6:33pm
To: Protopia
Cc: pyqt at riverbankcomputing.com
Subject: Re: [PyQt] Displaying . in a tableitem

On Fri, 29 Jul 2011 17:49:26 +0100, "Protopia" <pyqt4 at protopia.co.uk>
> I am trying to display . (i.e. not the three characters dot dot dot but
> the single character dotdotdot) in a tableitem, but is doesn't display.
> Is there something I need to set or a string conversion I need to do to
> make this work?

The following works for me...

import sys
from PyQt4.QtGui import QApplication, QListWidget, QListWidgetItem

app = QApplication(sys.argv)
lw = QListWidget()

QListWidgetItem(u"\N{horizontal ellipsis}", lw)



More information about the PyQt mailing list