[PyQt] Issue building latest PyQt4 snapshot against Qt 5.3.0

Detlev Offenbach detlev at die-offenbachs.de
Sat May 31 16:18:50 BST 2014


I tried to build the latest PyQt4 snapshot against Qt 5.3.0. The configure run failed (see below). 
Building it against Qt 4.8.6 worked fine.

~/py3qt50env/bin/python configure.py -b ~/py3qt50env/bin/ -v ~/py3qt50env/sip -c -j8 --verbose
Determining the layout of your Qt installation...
/usr/local/Qt-5.3/bin/qmake -o qtdirs.mk qtdirs.pro
make -f qtdirs.mk
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_CORE_LIB -
I/usr/local/Qt-5.3.0/mkspecs/linux-g++ -I. -I/usr/local/Qt-5.3.0/include -
I/usr/local/Qt-5.3.0/include/QtCore -I. -o qtdirs.o qtdirs.cpp
qtdirs.cpp: In function ‘int main(int, char**)’:
qtdirs.cpp:37:12: error: ‘QT_EDITION’ was not declared in this scope
     out << QT_EDITION << '\n';
make: *** [qtdirs.o] Fehler 1
Error: Failed to determine the layout of your Qt installation. Try again using
the --verbose flag to see more detail about the problem.

*Detlev Offenbach*
detlev at die-offenbachs.de
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20140531/ee3968e3/attachment.html>

More information about the PyQt mailing list