[PyQt] PyQt5.4.1 missing QtMultiMedia and QtWebEngineView modules

Rembrand at daxLAB rembrand at daxlab.com
Tue Aug 4 12:06:38 BST 2015

Dear all,

I'm still in the progress of porting my app from PyQt4 to PyQt5.
So far so good, it runs but now I want to make use of the Qt5 components (like QtMultiMedia, QtMultiMediaWidgets and QtWebEngineView) but I cant find them inside the site-packages/PyQt5  folder of python 2.7

This is what I did on my Fedora 20 64bit instance:

I  made sure that all Qt5 libs are installed as run-time libs and as far there where corresponding devel libs.

downloaded SIP (4.16.9)
downloaded PyQt 5.4.1.

Then I run for SIP: 
python configure.py 
make install

Then I run for PyQt5:
python configure,py -q /usr/lib64/qt5/bin/qmake
make install

However the components I did the porting in the first place for are missing:

In configure.py (which I did not edit/change) they are mentioned but there are no corresponding subdirs and corresponding .so files.

Do I have to specify them during the build (where/hown) or do I need to download the latest PyQT5 5.5 version?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riverbankcomputing.com/pipermail/pyqt/attachments/20150804/09bafe12/attachment.html>

More information about the PyQt mailing list