[PyQt] pyqtdeploy building demo problem with NDK

Ronald Petit elronaldpetit at gmail.com
Thu Aug 2 14:44:07 BST 2018

Sorry, it is not package manager, is archive manager, what Linux uses to
extract files from compressed ones.

And sorry again to be so annoying, but I really want to get this working, I
doubt that my Python doesn't support .xz, I'm using python 3.7, and python
is supposed to support .xz from 3.3, unless pyqtdeploy-sysroot is using
python 2.7 I don't see why I'm getting that error.

Where I can modify how pyqtdeploy-sysroot extracts tar files?, seems like a
common error when a tar file have multiple folders inside, which have no
sense, as Qt have one single folder with a lot of folders and files inside

El jue., 2 ago. 2018 a las 9:15, Phil Thompson (<phil at riverbankcomputing.com>)

> On 2 Aug 2018, at 2:06 pm, Ronald Petit <elronaldpetit at gmail.com> wrote:
> >
> > Thanks for your answers Phil.
> >
> > Now, targeting my host system, I'm getting "Unable to unpack
> qt-everywhere-src-5.11.0.tar.xz", I tried to unpack it myself, and takes
> like a minute just to open the package manager, is there a way to tell
> pyqtdeploy-sysroot to use an already extracted folder?.
> Only by providing your own Qt plugin for pyqtdeploy-sysroot that does what
> you want.
> What do you mean by "the package manager"?
> > In the verbose output it says "unknown archive format" but I was able to
> extract it by myself, I also tried redownloading it, but seems to be too
> large.
> I assume the error message is coming from Python which suggests your
> Python installation doesn't support .xz archives.
> Phil
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.riverbankcomputing.com/pipermail/pyqt/attachments/20180802/d6438c0d/attachment.html>

More information about the PyQt mailing list